[Mesa-dev] [PATCH 04/15] i965/fs: Rename "cont" to "progress" in dataflow algorithm.

Kenneth Graunke kenneth at whitecape.org
Mon Aug 12 13:11:24 PDT 2013


This variable indicates that the fixed-point algorithm made changes to
the data at this step, so it needs to run for another iteration.

"progress" seems a nicer name for that.
---
 src/mesa/drivers/dri/i965/brw_fs_copy_propagation.cpp | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/src/mesa/drivers/dri/i965/brw_fs_copy_propagation.cpp b/src/mesa/drivers/dri/i965/brw_fs_copy_propagation.cpp
index 5efa812..9204f0e 100644
--- a/src/mesa/drivers/dri/i965/brw_fs_copy_propagation.cpp
+++ b/src/mesa/drivers/dri/i965/brw_fs_copy_propagation.cpp
@@ -166,10 +166,10 @@ fs_copy_prop_dataflow::setup_kills()
 void
 fs_copy_prop_dataflow::run()
 {
-   bool cont;
+   bool progress;
 
    do {
-      cont = false;
+      progress = false;
 
       for (int b = 0; b < cfg->num_blocks; b++) {
          for (int i = 0; i < bitset_words; i++) {
@@ -178,7 +178,7 @@ fs_copy_prop_dataflow::run()
                                        ~bd[b].liveout[i]);
             if (new_liveout) {
                bd[b].liveout[i] |= new_liveout;
-               cont = true;
+               progress = true;
             }
 
             /* Update livein: if it's live at the end of all parents, it's
@@ -194,11 +194,11 @@ fs_copy_prop_dataflow::run()
             }
             if (new_livein) {
                bd[b].livein[i] |= new_livein;
-               cont = true;
+               progress = true;
             }
          }
       }
-   } while (cont);
+   } while (progress);
 }
 
 bool
-- 
1.8.3.4



More information about the mesa-dev mailing list