[Mesa-dev] [PATCH 03/23] glsl: Add helper methods to glsl_type for dealing with images.

Paul Berry stereotype441 at gmail.com
Wed Dec 11 13:19:51 PST 2013


On 26 November 2013 00:02, Francisco Jerez <currojerez at riseup.net> wrote:

> Add predicates to query if a GLSL type is or contains an image.
> Rename sampler_coordinate_components() to coordinate_components() and
> fix it to support calculating the number of coordinate dimensions of
> image types as well as sampler types.
> ---
>  src/glsl/builtin_functions.cpp        |  2 +-
>  src/glsl/glsl_types.cpp               | 95
> +++++++++++++++++++++++++----------
>  src/glsl/glsl_types.h                 | 19 ++++++-
>  src/glsl/tests/sampler_types_test.cpp |  2 +-
>  4 files changed, 88 insertions(+), 30 deletions(-)
>

If the calls to unreachable() are replaced with assertions (as we've
discussed elsewhere on the list), this patch is:

Reviewed-by: Paul Berry <stereotype441 at gmail.com>

I don't have a strong opinion about Topi's suggestion to separate the
sampler and image cases--I could go either way.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/mesa-dev/attachments/20131211/9f6f831e/attachment.html>


More information about the mesa-dev mailing list