[Mesa-dev] [PATCH] mesa: Rename gl_context::swtnl_im to vbo_context.

Eric Anholt eric at anholt.net
Thu Mar 21 12:04:21 PDT 2013


Kenneth Graunke <kenneth at whitecape.org> writes:

> The main GL context's swtnl_im field is the VBO module's vbo_context
> structure.  Using the name "swtnl" in the name is confusing since
> some drivers use hardware texturing and lighting, but still rely on the
> VBO module for drawing.
>
> Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>
> ---
>  src/mesa/main/mtypes.h     | 2 +-
>  src/mesa/vbo/vbo_context.c | 4 ++--
>  src/mesa/vbo/vbo_context.h | 2 +-
>  3 files changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/src/mesa/main/mtypes.h b/src/mesa/main/mtypes.h
> index 8c38aa7..7900897 100644
> --- a/src/mesa/main/mtypes.h
> +++ b/src/mesa/main/mtypes.h
> @@ -3613,7 +3613,7 @@ struct gl_context
>     void *swrast_context;
>     void *swsetup_context;
>     void *swtnl_context;
> -   void *swtnl_im;
> +   void *vbo_context;
>     struct st_context *st;
>     void *aelt_context;
>     /*@}*/

Could we forward declare struct vbo_context and use the actual type
here?  That would clarify things even further, and avoid gratuitous
casting.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
URL: <http://lists.freedesktop.org/archives/mesa-dev/attachments/20130321/46d81a4c/attachment.pgp>


More information about the mesa-dev mailing list