[Mesa-dev] [PATCH] i965: Replace 'noann' debug flag with 'ann'.
Kenneth Graunke
kenneth at whitecape.org
Sat Dec 6 03:23:54 PST 2014
On Friday, December 05, 2014 05:08:40 PM Matt Turner wrote:
> ---
> Eric was against making this the default when I first suggested a flag.
> Have opinions changed since then? I rarely use the annotations, and they
> do make the assembly harder to read, when the assembly is what you're
> interested in.
>
> src/mesa/drivers/dri/i965/intel_asm_annotation.c | 2 +-
> src/mesa/drivers/dri/i965/intel_debug.c | 2 +-
> src/mesa/drivers/dri/i965/intel_debug.h | 2 +-
> 3 files changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/src/mesa/drivers/dri/i965/intel_asm_annotation.c b/src/mesa/drivers/dri/i965/intel_asm_annotation.c
> index 37ad090..ac12655 100644
> --- a/src/mesa/drivers/dri/i965/intel_asm_annotation.c
> +++ b/src/mesa/drivers/dri/i965/intel_asm_annotation.c
> @@ -109,7 +109,7 @@ void annotate(struct brw_context *brw,
>
> struct annotation *ann = &annotation->ann[annotation->ann_count++];
> ann->offset = offset;
> - if ((INTEL_DEBUG & DEBUG_NO_ANNOTATION) == 0) {
> + if ((INTEL_DEBUG & DEBUG_ANNOTATION) != 0) {
> ann->ir = inst->ir;
> ann->annotation = inst->annotation;
> }
> diff --git a/src/mesa/drivers/dri/i965/intel_debug.c b/src/mesa/drivers/dri/i965/intel_debug.c
> index 6391cf7..1dd2b1d 100644
> --- a/src/mesa/drivers/dri/i965/intel_debug.c
> +++ b/src/mesa/drivers/dri/i965/intel_debug.c
> @@ -66,7 +66,7 @@ static const struct dri_debug_control debug_control[] = {
> { "blorp", DEBUG_BLORP },
> { "nodualobj", DEBUG_NO_DUAL_OBJECT_GS },
> { "optimizer", DEBUG_OPTIMIZER },
> - { "noann", DEBUG_NO_ANNOTATION },
> + { "ann", DEBUG_ANNOTATION },
> { "no8", DEBUG_NO8 },
> { NULL, 0 }
> };
> diff --git a/src/mesa/drivers/dri/i965/intel_debug.h b/src/mesa/drivers/dri/i965/intel_debug.h
> index e859be1..a01de21 100644
> --- a/src/mesa/drivers/dri/i965/intel_debug.h
> +++ b/src/mesa/drivers/dri/i965/intel_debug.h
> @@ -61,7 +61,7 @@ extern uint64_t INTEL_DEBUG;
> #define DEBUG_VUE (1 << 25)
> #define DEBUG_NO_DUAL_OBJECT_GS (1 << 26)
> #define DEBUG_OPTIMIZER (1 << 27)
> -#define DEBUG_NO_ANNOTATION (1 << 28)
> +#define DEBUG_ANNOTATION (1 << 28)
> #define DEBUG_NO8 (1 << 29)
>
> #ifdef HAVE_ANDROID_PLATFORM
>
Sounds good to me.
Reviewed-by: Kenneth Graunke <kenneth at whitecape.org>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: This is a digitally signed message part.
URL: <http://lists.freedesktop.org/archives/mesa-dev/attachments/20141206/3c5e4c3a/attachment.sig>
More information about the mesa-dev
mailing list