[Mesa-dev] [PATCH 1/2] glsl: Rename "expr" to "lhs_expr" in vector_extract munging code.
Kenneth Graunke
kenneth at whitecape.org
Fri Jan 24 11:48:45 PST 2014
When processing assignments, we have both an LHS and RHS. At a glance,
"lhs_expr" clearly refers to the LHS, while a generic name like "expr"
is ambiguous.
Cc: idr at freedesktop.org
Cc: mesa-stable at lists.freedesktop.org
Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>
---
src/glsl/ast_to_hir.cpp | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/src/glsl/ast_to_hir.cpp b/src/glsl/ast_to_hir.cpp
index c71078e..67ab09b 100644
--- a/src/glsl/ast_to_hir.cpp
+++ b/src/glsl/ast_to_hir.cpp
@@ -745,9 +745,9 @@ do_assignment(exec_list *instructions, struct _mesa_glsl_parse_state *state,
* expression, move it to the RHS as an ir_triop_vector_insert.
*/
if (lhs->ir_type == ir_type_expression) {
- ir_expression *const expr = lhs->as_expression();
+ ir_expression *const lhs_expr = lhs->as_expression();
- if (unlikely(expr->operation == ir_binop_vector_extract)) {
+ if (unlikely(lhs_expr->operation == ir_binop_vector_extract)) {
ir_rvalue *new_rhs =
validate_assignment(state, lhs_loc, lhs->type,
rhs, is_initializer);
@@ -756,11 +756,11 @@ do_assignment(exec_list *instructions, struct _mesa_glsl_parse_state *state,
return lhs;
} else {
rhs = new(ctx) ir_expression(ir_triop_vector_insert,
- expr->operands[0]->type,
- expr->operands[0],
+ lhs_expr->operands[0]->type,
+ lhs_expr->operands[0],
new_rhs,
- expr->operands[1]);
- lhs = expr->operands[0]->clone(ctx, NULL);
+ lhs_expr->operands[1]);
+ lhs = lhs_expr->operands[0]->clone(ctx, NULL);
}
}
}
--
1.8.5.2
More information about the mesa-dev
mailing list