[Mesa-dev] [PATCH 3/8] dri: Change __DriverApiRec::CreateContext to take a struct for attribs
neil at linux.intel.com
Fri Oct 24 07:37:05 PDT 2014
Ian Romanick <idr at freedesktop.org> writes:
> Hmm... There's a flag. The flag says whether a field is valid. When
> the field is valid, there is only one possible value for that field.
> This seems weird to me. If the field can have only one value, we don't
> really need it. This applies to the next patch as well.
I'm not really convinced that replacing the value with just the flag
would make the code cleaner. Although both of the attributes actually
only have two possible values each, I don't think they are really
treated as just true or false values in GL so it would be confusing to
map them to just true or false in the driver. Using the flag in
attribute_mask directly to store the value means attribute_mask would be
a bit of a misnomer and instead it is something like
attribute_mask_and_flags. If we went down the flags route then maybe it
would make sense to just get rid of the struct for now and only have the
flags because it might be that we never end up adding an attribute that
doesn't fit into an on/off flag.
I think my preferred solution would be to keep the patch as it is for
the most flexibility and consistency. However I don't want to be accused
of bike-shedding so if you strongly think we should use the flag
directly then I am happy to make it like that.
More information about the mesa-dev