[Mesa-dev] [PATCH] i965: Rename INTEL_DEBUG=vec4vs to INTEL_DEBUG=vec4.

Kenneth Graunke kenneth at whitecape.org
Wed Aug 26 02:43:23 PDT 2015


driParseDebugString() doesn't have actual code to parse comma separated
lists (or any other supported options?); instead it dumbly uses strstr().

This means that INTEL_DEBUG="vec4vs" will trigger both DEBUG_VEC4VS and
DEBUG_VS, as "vs" is also a substring.

We should probably improve the driconf parsing, but for now, just rename
the option so it's usable in the meantime.

Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>
---
 src/mesa/drivers/dri/i965/intel_debug.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/src/mesa/drivers/dri/i965/intel_debug.c b/src/mesa/drivers/dri/i965/intel_debug.c
index a077731..b3b3c21 100644
--- a/src/mesa/drivers/dri/i965/intel_debug.c
+++ b/src/mesa/drivers/dri/i965/intel_debug.c
@@ -68,7 +68,7 @@ static const struct dri_debug_control debug_control[] = {
    { "optimizer",   DEBUG_OPTIMIZER },
    { "ann",         DEBUG_ANNOTATION },
    { "no8",         DEBUG_NO8 },
-   { "vec4vs",      DEBUG_VEC4VS },
+   { "vec4",        DEBUG_VEC4VS },
    { "spill",       DEBUG_SPILL },
    { "cs",          DEBUG_CS },
    { NULL,    0 }
-- 
2.5.0



More information about the mesa-dev mailing list