[Mesa-dev] [PATCH 3/6] i965/fs: Add set_sechalf() method.
currojerez at riseup.net
Mon May 18 12:07:52 PDT 2015
Matt Turner <mattst88 at gmail.com> writes:
> On Fri, May 15, 2015 at 2:46 PM, Francisco Jerez <currojerez at riseup.net> wrote:
>> Matt Turner <mattst88 at gmail.com> writes:
>>> Used in the next commit.
>>> src/mesa/drivers/dri/i965/brw_ir_fs.h | 10 ++++++++++
>>> 1 file changed, 10 insertions(+)
>>> diff --git a/src/mesa/drivers/dri/i965/brw_ir_fs.h b/src/mesa/drivers/dri/i965/brw_ir_fs.h
>>> index 7ac7ff8..a79713c 100644
>>> --- a/src/mesa/drivers/dri/i965/brw_ir_fs.h
>>> +++ b/src/mesa/drivers/dri/i965/brw_ir_fs.h
>>> @@ -261,4 +261,14 @@ public:
>>> bool pi_noperspective:1; /**< Pixel interpolator noperspective flag */
>>> + * Set second-half quarter control on \p inst.
>>> + */
>>> +static inline fs_inst *
>>> +set_sechalf(fs_inst *inst)
>>> + inst->force_sechalf = true;
>>> + return inst;
>> Hey Matt, just a quick request that would make this helper more useful:
>> Can we make this take the half as an index integer argument (and maybe
>> rename it to set_half), just like the half() register helper does? That
>> would allow using it in a loop, for instance.
> I feel a little weird making a decision about the interface when I'm
> not /really/ using the function (patch 6/6 removes uses of it).
Yeah. And still you *are* making a decision about the interface now. :P
> I'm not opposed to the changes you suggest, so lets change it in
> another series that can make use of the new interface.
In that case why don't you define it locally in the source file that
uses it and then remove it altogether? It doesn't seem particularly
useful in its current form.
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 212 bytes
Desc: not available
More information about the mesa-dev