[Mesa-dev] [PATCH 07/13] isl/format: Break the guts of has_[us]int_channel into a helper

Chad Versace chad.versace at intel.com
Tue Apr 19 22:38:14 UTC 2016


On Sat 16 Apr 2016, Jason Ekstrand wrote:
> ---
>  src/intel/isl/isl_format.c | 34 ++++++++++++++++------------------
>  1 file changed, 16 insertions(+), 18 deletions(-)
> 
> diff --git a/src/intel/isl/isl_format.c b/src/intel/isl/isl_format.c
> index 32bd701..b0450d9 100644
> --- a/src/intel/isl/isl_format.c
> +++ b/src/intel/isl/isl_format.c
> @@ -25,32 +25,30 @@
>  
>  #include "isl.h"
>  
> -bool
> -isl_format_has_uint_channel(enum isl_format fmt)
> +static inline bool
> +isl_format_has_channel_of_type(enum isl_format fmt, enum isl_base_type type)

I think the 'of' in the function name sounds awkward, a little Java-ish.
'isl_format_has_channel_type' sounds better.

With or without the change, patch 7 is
Reviewed-by: Chad Versace <chad.versace at intel.com>



More information about the mesa-dev mailing list