[Mesa-dev] [Bug 94291] llvmpipe tests fail if built on skylake i7-6700k

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Wed Apr 20 15:56:31 UTC 2016


--- Comment #9 from Roland Scheidegger <sroland at vmware.com> ---
(In reply to Timo Aaltonen from comment #8)
> Actually it wasn't avx512, that was the first one I tried :) It's enabled
> also on 3.7 and that version works fine. Only one that was added in 3.8 is
> PKU, but dropping just that didn't help.
> I did try dropping all non-client features (AVX512, CDI, DQI, BWI, VLX, PKU)
> and that worked. Maybe one of CDI/DQI/BWI/VLX is somewhat broken on 3.8?

Which is why I said "or any subvariant" ;-).
ERI, CDI, PFI, DQI, BWI, VLX are all avx512 variants (omg naming???), though
that skylake in the llvm 3.8 list doesn't suport ERI and PFI. I'm not sure, but
probably dropping avx512 manually when a enhanced variant still gets enabled
won't do anything. I don't think PKU would matter (but no guarantee...). I
suppose we should explicitly disable all of them via mattrs too (not that it's
a battle we can win, there will be some extensions at some point...).

You are receiving this mail because:
You are the QA Contact for the bug.
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.freedesktop.org/archives/mesa-dev/attachments/20160420/0a2d83ee/attachment.html>

More information about the mesa-dev mailing list