[Mesa-dev] [PATCH 1/9] st/mesa: rename st_readpixels to st_ReadPixels

Brian Paul brianp at vmware.com
Tue Feb 23 23:45:17 UTC 2016


To match the convention of other device driver functions.
---
 src/mesa/state_tracker/st_cb_readpixels.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/src/mesa/state_tracker/st_cb_readpixels.c b/src/mesa/state_tracker/st_cb_readpixels.c
index 6dc2661..5153c4b 100644
--- a/src/mesa/state_tracker/st_cb_readpixels.c
+++ b/src/mesa/state_tracker/st_cb_readpixels.c
@@ -81,7 +81,7 @@ needs_integer_signed_unsigned_conversion(const struct gl_context *ctx,
  *       we do here should be free in such cases.
  */
 static void
-st_readpixels(struct gl_context *ctx, GLint x, GLint y,
+st_ReadPixels(struct gl_context *ctx, GLint x, GLint y,
               GLsizei width, GLsizei height,
               GLenum format, GLenum type,
               const struct gl_pixelstore_attrib *pack,
@@ -257,5 +257,5 @@ fallback:
 
 void st_init_readpixels_functions(struct dd_function_table *functions)
 {
-   functions->ReadPixels = st_readpixels;
+   functions->ReadPixels = st_ReadPixels;
 }
-- 
1.9.1



More information about the mesa-dev mailing list