[Mesa-dev] [PATCH 0/7] nv50: rework compute/3d validation path

Samuel Pitoiset samuel.pitoiset at gmail.com
Tue Mar 15 19:54:49 UTC 2016


From: Samuel Pitoiset <samuel.pitoiset at gmail.com>

Hi,

This is loosely based on what I did for nvc0 few weeks ago. I have not tested
this series because I don't have access to a Tesla card, but this should not
break anything. By the way, doing almost the same series twice is not so cool
but... refactoring nv50 and nvc0 drivers seems to be worse. :-)

Please review,
Thanks.

Samuel Pitoiset (7):
  nv50: rename nv50_context::dirty to nv50_context::dirty_3d
  nv50: rename NV50_COMPUTE to NV50_CP
  nv50: rename 3d dirty flags to NV50_NEW_3D_XXX
  nv50: rename 3d binding points to NV50_BIND_3D_XXX
  nv50: rework the validation path for 3D
  nv50: rework nv50_compute_validate_program()
  nv50: add a new validation path for compute

 src/gallium/drivers/nouveau/nv50/nv50_compute.c    | 145 +++++++++------------
 src/gallium/drivers/nouveau/nv50/nv50_context.c    |  34 ++---
 src/gallium/drivers/nouveau/nv50/nv50_context.h    |  77 ++++++-----
 .../drivers/nouveau/nv50/nv50_query_hw_sm.c        |  10 +-
 .../drivers/nouveau/nv50/nv50_shader_state.c       |  37 ++++--
 src/gallium/drivers/nouveau/nv50/nv50_state.c      |  54 ++++----
 .../drivers/nouveau/nv50/nv50_state_validate.c     | 136 ++++++++++---------
 src/gallium/drivers/nouveau/nv50/nv50_surface.c    |  40 +++---
 src/gallium/drivers/nouveau/nv50/nv50_tex.c        |   2 +-
 src/gallium/drivers/nouveau/nv50/nv50_vbo.c        |  14 +-
 src/gallium/drivers/nouveau/nv50/nv50_winsys.h     |   4 +-
 11 files changed, 280 insertions(+), 273 deletions(-)

-- 
2.7.3



More information about the mesa-dev mailing list