[Mesa-dev] [PATCH 8/8] radeonsi/sid_tables: rename reg_table to sid_reg_table
Nicolai Hähnle
nhaehnle at gmail.com
Mon May 9 16:32:27 UTC 2016
From: Nicolai Hähnle <nicolai.haehnle at amd.com>
This is purely cosmetic, making it easier to assign blame for space used
in the binary in case somebody else makes a similar cleanup effort in the
future.
---
src/gallium/drivers/radeonsi/si_debug.c | 4 ++--
src/gallium/drivers/radeonsi/sid_tables.py | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/src/gallium/drivers/radeonsi/si_debug.c b/src/gallium/drivers/radeonsi/si_debug.c
index f7393d6..783dee4 100644
--- a/src/gallium/drivers/radeonsi/si_debug.c
+++ b/src/gallium/drivers/radeonsi/si_debug.c
@@ -185,8 +185,8 @@ static void si_dump_reg(FILE *file, unsigned offset, uint32_t value,
{
int r, f;
- for (r = 0; r < ARRAY_SIZE(reg_table); r++) {
- const struct si_reg *reg = ®_table[r];
+ for (r = 0; r < ARRAY_SIZE(sid_reg_table); r++) {
+ const struct si_reg *reg = &sid_reg_table[r];
const char *reg_name = sid_strings + reg->name_offset;
if (reg->offset == offset) {
diff --git a/src/gallium/drivers/radeonsi/sid_tables.py b/src/gallium/drivers/radeonsi/sid_tables.py
index 0ca24ae..7ba0215 100755
--- a/src/gallium/drivers/radeonsi/sid_tables.py
+++ b/src/gallium/drivers/radeonsi/sid_tables.py
@@ -262,7 +262,7 @@ struct si_packet3 {
print '};'
print
- print 'static const struct si_reg reg_table[] = {'
+ print 'static const struct si_reg sid_reg_table[] = {'
for reg in regs:
if len(reg.fields):
print '\t{%s, %s, %s, %s},' % (strings.add(reg.name), reg.r_name,
--
2.7.4
More information about the mesa-dev
mailing list