[Mesa-dev] [Bug 69101] prime: black window

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Thu May 12 12:38:31 UTC 2016


Mez <mezcalbert at hotmail.com> changed:

           What    |Removed                     |Added
                 CC|                            |mezcalbert at hotmail.com

--- Comment #31 from Mez <mezcalbert at hotmail.com> ---
I also have a very similar problem except the windows are... white.

Setup is hybrid muxless AMD/AMD (6480G/6650M). I'm running on Ubuntu
16.04/Unity (meaning Compiz) with Mesa 11.2 (or 11.3-devel) and on kernel

The issue only occurs when booting without grub options (dpm is thus enabled by
default), it may be linked to another issue which is that the xrandr
--listproviders only outputs iGPU when DPM is enabled (even if I use
DRI_PRIME=1), though DRI_PRIME=1 glxinfo | grep OpenGL outputs the dGPU as it

DPM on, and with DRI3 enabled in /etc/X11/xorg.conf.d/r.conf, if I launch apps
with DRI_PRIME=1 %command%, it renders a white window (no decorations). I don't
think resizing the window works, not sure I've ever tried.
vgaswitcheroo shows DynPwr on the dGPU when DRI_PRIME=1 is used (DynOff
otherwise) and the fans are definitely going a notch higher, meaning it looks
like it works, just the rendering that is off (well, white). 

If I stay on DRI2, the rendering on windows works fine, though DRI_PRIME=1
launches on integrated GPU (half of the fps, and dGPU remains on DynOff).

If I insert radeon.runpm=0 as grub option, still on DRI3, both GPUS are listed
with xrandr --listproviders and vgaswitcheroo outputs Pwr for both (not good
for battery life), only then DRI_PRIME=1 is working nice with dGPU, though
system freezes when navigating context menus in Steam (unless I add
LIBGL_DRI3_DISABLE=1 before DRI_PRIME=1 %command%).

To summarize, white windows occurs only with dpm on, DRI3 enabled and launching
apps with DRI_PRIME=1. With a different configuration, it has other kind of
issues. No perfect setup yet (except discontinued fglrx).

I still have to try this on Manjaro on a test partition to see if it the
results are the same.

Anyway, this bug is not solved.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.freedesktop.org/archives/mesa-dev/attachments/20160512/bbd1bafe/attachment.html>

More information about the mesa-dev mailing list