[Mesa-dev] [Bug 98320] phytec bitbake recipe for i.MX6 deployment does not produce libGL

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Wed Oct 19 14:29:28 UTC 2016


            Bug ID: 98320
           Summary: phytec bitbake recipe for i.MX6 deployment does not
                    produce libGL
           Product: Mesa
           Version: unspecified
          Hardware: Other
                OS: Linux (All)
            Status: NEW
          Severity: major
          Priority: medium
         Component: GLU
          Assignee: mesa-dev at lists.freedesktop.org
          Reporter: patricia_sandt at trimble.com
        QA Contact: mesa-dev at lists.freedesktop.org

I'm working under the assumption that mesa provides libGL. If not, please tell
me who does provide it (hardware specific). I am building mesa for a Phytec
module for an i.MX6 development board. I downloaded the
recipes-graphics/mesa/mesa_%.bbappend and bitbaked mesa. As long as I delete
the tmp directory and deploy directory, the build completes successfully.
However, when I tried to build FreeGLUT, I was told that libGL did not exist
when it tries to build libGLU. The actual message is "cannot find -lGL". I can
provide the log output, but it doesn't provide much additional information. I
tried to find the library location with 

find . -name libGL.so
No files were found (and the command should have found libGL.so.* matches.)

You are receiving this mail because:
You are the assignee for the bug.
You are the QA Contact for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.freedesktop.org/archives/mesa-dev/attachments/20161019/995ac440/attachment.html>

More information about the mesa-dev mailing list