[Mesa-dev] [PATCH 1/9] compiler: Add new system value SYSTEM_VALUE_BASE_VERTEX_ID
apuentes at igalia.com
Mon Dec 4 20:17:40 UTC 2017
On 30/11/17 21:43, Neil Roberts wrote:
> Kenneth Graunke <kenneth at whitecape.org> writes:
>> We have a number of similar names now:
>> BASE_VERTEX and BASE_VERTEX_ID are really similar names, and honestly
>> either one seems like it could be the name for gl_BaseVertex. I'm
>> afraid it would be easy to mix them up by mistake. IMHO, it would be
>> nice to pick a different word, just to keep some distinction between
>> the two fairly related concepts...
>> Perhaps SYSTEM_VALUE_FIRST_VERTEX...? That's only half the meaning,
>> but it at least uses a different word, and makes you think "do I want
>> BASE_VERTEX or FIRST_VERTEX?"
> Yes, naming this thing is really difficult. I’m not sure if you noticed,
> but for Vulkan, the BaseVertex builtin should actually have the value of
> BASE_VERTEX_ID unlike GL. So if we rename BASE_VERTEX to something
> without “base vertex” in it then it will still be confusing for Vulkan.
> So effectively the descriptive names are like:
> I’m not sure whether that’s enough of an argument against FIRST_VERTEX
> though, so personally I don’t really mind either way.
> Antia, what do you think?
I am fine renaming it to FIRST_VERTEX. I have sent a second version of
the series with the renaming and addressing other feedback given by Kenneth.
More information about the mesa-dev