[Mesa-dev] Query with respect to support of x32

Haridasan, Sujith Sujith_Haridasan at mentor.com
Wed Feb 15 12:57:51 UTC 2017


I am getting same result with 17.0.x which I got for version 13 ( of Mesa). Not sure if Qt has something to do with this. I am using Qt version 5.6.

Sujith H
-----Original Message-----
From: mesa-dev [mailto:mesa-dev-bounces at lists.freedesktop.org] On Behalf Of Haridasan, Sujith
Sent: 15 February 2017 12:44
To: Emil Velikov <emil.l.velikov at gmail.com>
Cc: mesa-dev at lists.freedesktop.org
Subject: Re: [Mesa-dev] Query with respect to support of x32

Hi Emil,

I tried with 13.0.4 version. The mesa demos are working fine with that version. Qt 5.6 has no luck. I am getting the bus error.
I will try with 17.0.x version and will update here. Now I am happy that mesa demos are working with version 13.

Sujith H

-----Original Message-----
From: Emil Velikov [mailto:emil.l.velikov at gmail.com]
Sent: 14 February 2017 19:46
To: Haridasan, Sujith <Sujith_Haridasan at mentor.com>
Cc: mesa-dev at lists.freedesktop.org
Subject: Re: [Mesa-dev] Query with respect to support of x32

Hi Sujith,

On 14 February 2017 at 13:12, Haridasan, Sujith <Sujith_Haridasan at mentor.com> wrote:
> Hi,
> I am using mesa 12.0.1 from yocto project 
> (http://git.yoctoproject.org/cgit/cgit.cgi/poky/tree/meta/recipes-graphics/mesa/mesa_12.0.1.bb?h=morty).
> While building core-image-sato ( which is the graphical image ), I 
> found that Qt5 examples for opengl are failing for x32. The target 
> machine used is intel-corei7-64. This is for minnowmax board. The 
> image uses mesa and below is the console log of one of the Qt5 example ran on the target:
Keep in mind that the Mesa 12.0.x series is EOL. I would suggest using 13.0.x or 17.0.x although first testing git is the better thing to do.

If things still fail, fleshing out a simple test program (ideally one that does not depend on QT/other frameworks) and opening a bug [1] would be appreciated.
To track if it's driver related you can set LIBGL_ALWAYS_SOFTWARE=1 prior to starting your app. This will use the SW rasteriser, swrast_dri.so.


[1] https://bugs.freedesktop.org/
mesa-dev mailing list
mesa-dev at lists.freedesktop.org

More information about the mesa-dev mailing list