[Mesa-dev] [PATCH 09/22] nir/format_convert: Rename pack_r11g11b10f to pack_11f11f10f
Jason Ekstrand
jason at jlekstrand.net
Fri Aug 17 20:06:15 UTC 2018
This matches the unpack function.
---
src/compiler/nir/nir_format_convert.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/compiler/nir/nir_format_convert.h b/src/compiler/nir/nir_format_convert.h
index 75793733ea6..c79001a50aa 100644
--- a/src/compiler/nir/nir_format_convert.h
+++ b/src/compiler/nir/nir_format_convert.h
@@ -298,7 +298,7 @@ nir_format_unpack_11f11f10f(nir_builder *b, nir_ssa_def *packed)
}
static inline nir_ssa_def *
-nir_format_pack_r11g11b10f(nir_builder *b, nir_ssa_def *color)
+nir_format_pack_11f11f10f(nir_builder *b, nir_ssa_def *color)
{
/* 10 and 11-bit floats are unsigned. Clamp to non-negative */
nir_ssa_def *clamped = nir_fmax(b, color, nir_imm_float(b, 0));
--
2.17.1
More information about the mesa-dev
mailing list