[Mesa-dev] [Bug 107777] No 3D in "Vampire: The Masquerade - Bloodlines" when d3d-nine enabled

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Fri Aug 31 19:50:04 UTC 2018


            Bug ID: 107777
           Summary: No 3D in "Vampire: The Masquerade - Bloodlines" when
                    d3d-nine enabled
           Product: Mesa
           Version: 18.2
          Hardware: x86-64 (AMD64)
                OS: Linux (All)
            Status: NEW
          Severity: normal
          Priority: medium
         Component: Gallium/StateTracker/galliumnine
          Assignee: mesa-dev at lists.freedesktop.org
          Reporter: inferrna at gmail.com
        QA Contact: mesa-dev at lists.freedesktop.org

Created attachment 141398
  --> https://bugs.freedesktop.org/attachment.cgi?id=141398&action=edit
Resolution issue. Also no HUD displayed.

Using wine from https://launchpad.net/~commendsarnex/+archive/ubuntu/winedri3
on empty profile. With gallium nine off game (GOG version) runs just fine. But
there is at least 2 faults when nine enabled:
1. After opening videos shown there it no any menus - just black screen keeping
last frame of the last video.
2. Running in fullscreen mode, but resolution don't changed - all videos showed
in top-left corner of main screen (see attachment).

no any special errors in wine output.
Tried with mesa 18.05 and 18.2-rc5

Tried some debug:
env GALLIUM_HUD="fps,requested-VRAM"  LIBGL_DEBUG=verbose
WINEDEBUG="-all" WINEPREFIX="/tmp/empty" WINE=/opt/wine-d3d9-staging/bin/wine
/opt/wine-d3d9-staging/bin/wine vampire.exe


/usr/share/libdrm/amdgpu.ids version: 1.0.0
libGL: pci id for fd 78: 1002:67ff, driver radeonsi
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/tls/radeonsi_dri.so
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/radeonsi_dri.so
mesa: for the -simplifycfg-sink-common option: may only occur zero or one
mesa: for the -global-isel-abort option: may only occur zero or one times!
libGL: Using DRI3 for screen 0

and screenshot in attachment.
Also filed bug here https://bugs.winehq.org/show_bug.cgi?id=45745

You are receiving this mail because:
You are the assignee for the bug.
You are the QA Contact for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.freedesktop.org/archives/mesa-dev/attachments/20180831/fdc81b91/attachment-0001.html>

More information about the mesa-dev mailing list