[Mesa-dev] [PATCH v2 3/3] panfrost: Stop passing a ctx to functions being passed a batch

Boris Brezillon boris.brezillon at collabora.com
Sat Aug 31 17:19:18 UTC 2019


On Sat, 31 Aug 2019 17:12:33 +0100
Daniel Stone <daniel at fooishbar.org> wrote:

> Hi Boris,
> 
> On Sat, 31 Aug 2019 at 08:53, Boris Brezillon
> <boris.brezillon at collabora.com> wrote:
> > @@ -123,8 +123,7 @@ struct panfrost_batch *
> >  panfrost_job_create_batch(struct panfrost_context *ctx);
> >
> >  void
> > -panfrost_job_free_batch(struct panfrost_context *ctx,
> > -                        struct panfrost_batch *batch);
> > +panfrost_job_free_batch(struct panfrost_batch *batch);
> >
> >  struct panfrost_batch *
> >  panfrost_job_get_batch(struct panfrost_context *ctx,
> > @@ -149,18 +148,16 @@ panfrost_flush_jobs_reading_resource(struct panfrost_context *panfrost,
> >                                       struct pipe_resource *prsc);
> >
> >  void
> > -panfrost_job_submit(struct panfrost_context *ctx, struct panfrost_batch *batch);
> > +panfrost_job_submit(struct panfrost_batch *batch);
> >
> >  void
> > -panfrost_job_set_requirements(struct panfrost_context *ctx,
> > -                              struct panfrost_batch *batch);
> > +panfrost_job_set_requirements(struct panfrost_batch *batch);
> >
> >  mali_ptr
> >  panfrost_job_get_polygon_list(struct panfrost_batch *batch, unsigned size);
> >
> >  void
> > -panfrost_job_clear(struct panfrost_context *ctx,
> > -                   struct panfrost_batch *batch,
> > +panfrost_job_clear(struct panfrost_batch *batch,
> >                     unsigned buffers,
> >                     const union pipe_color_union *color,
> >                     double depth, unsigned stencil);  
> 
> The series looks good to me and is:
> Reviewed-by: Daniel Stone <daniels at collabora.com>
> 
> But as a follow-on, it seems like most of the panfrost_job_*()
> functions should probably be panfrost_batch_*() to reduce confusion.

I'd rather do this rename only once. I'll send a v3 with
s/panfrost_job_/panfrost_batch_/g.

Thanks for the review.

Boris


More information about the mesa-dev mailing list