[Mesa-dev] [PATCH 1/4] util: Add a drm_find_modifier helper

Eric Engestrom eric.engestrom at intel.com
Thu Mar 14 09:51:37 UTC 2019


On Thursday, 2019-03-14 04:19:02 +0000, Alyssa Rosenzweig wrote:
> This function is replicated across vc4/v3d/freedreno and is needed in
> Panfrost; let's make this shared code.
> 
> Signed-off-by: Alyssa Rosenzweig <alyssa at rosenzweig.io>
> ---
>  src/util/u_drm.h | 46 ++++++++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 46 insertions(+)
>  create mode 100644 src/util/u_drm.h
> 
> diff --git a/src/util/u_drm.h b/src/util/u_drm.h
> new file mode 100644
> index 00000000000..d543c9a7543
> --- /dev/null
> +++ b/src/util/u_drm.h
> @@ -0,0 +1,46 @@
> +/*
> + * Copyright © 2014 Broadcom
> + * Copyright (C) 2012 Rob Clark <robclark at freedesktop.org>
> + *
> + * Permission is hereby granted, free of charge, to any person obtaining a
> + * copy of this software and associated documentation files (the "Software"),
> + * to deal in the Software without restriction, including without limitation
> + * the rights to use, copy, modify, merge, publish, distribute, sublicense,
> + * and/or sell copies of the Software, and to permit persons to whom the
> + * Software is furnished to do so, subject to the following conditions:
> + *
> + * The above copyright notice and this permission notice (including the next
> + * paragraph) shall be included in all copies or substantial portions of the
> + * Software.
> + *
> + * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
> + * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
> + * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  IN NO EVENT SHALL
> + * THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
> + * LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
> + * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
> + * IN THE SOFTWARE.
> + */
> +
> +#ifndef U_DRM_H
> +#define U_DRM_H
> +
> +#include <stdint.h>
> +
> +/* Given a list of `count` DRM modifiers `haystack` and a desired modifier
> + * `needle`, returns whether the modifier is found */
> +
> +static bool
> +drm_find_modifier(uint64_t needle, const uint64_t *haystack, unsigned count)
> +{
> +        unsigned i;
> +
> +        for (i = 0; i < count; i++) {
> +                if (haystack[i] == needle)
> +                        return true;
> +        }
> +
> +        return false;
> +}

This is an extremely generic loop; it has nothing to do with modifiers,
they just happen to be uint64_t.

Can we call it something like this?
  static inline bool
  array_contains_u64(uint64_t *array, size_t array_size, uint64_t needle)

There could be other places that could use this function (or its
u32/s64/s32 equivalents), there's no reason to prevent its adoption with
a too specific name :)

With a generic name (and the missing `inline` Christian also mentioned),
the series is:
Reviewed-by: Eric Engestrom <eric.engestrom at intel.com>


More information about the mesa-dev mailing list