Question: error when running [Virtio-GPU Venus->vtest]

Gert Wollny gw.fossdev at
Tue Nov 8 10:35:32 UTC 2022


On Sun, 2022-11-06 at 11:33 -0800, Rob Clark wrote:
> On Fri, Nov 4, 2022 at 1:42 AM Taylor Viktor <sysescool at>
> wrote:
> > 
> > Dear Developers:
> > 
> > I am referring to this document
> > to develop vulkan
> > related functions, but every time I run vulkaninfo or vkcube some
> > errors occur.
> > 
> > virgl_test_server prints the following:
> > 
> > gl_version 46 - core profile enabled
> > vtest_client_dispatch_commands: client context created. client
> > failed: VTEST_CLIENT_ERROR_INPUT_READvulkaninfo
> I'm not sure about the venus/vk case, but I got the same error when
> trying to use virgl+vtest the other day.  I think this must have
> broken semi-recently, but didn't try to bisect or figure out if the
> issue was in mesa or virglrenderer

The error message 
   "client failed: VTEST_CLIENT_ERROR_INPUT_READ" 
is also emitted when the guest client exits normally, this is a bit
unfortunate, but IMSMR it was not possible to distinguish between the
client just finishing or whether something had gone wrong with the file

AFAIR this has been printed since the beginning, and OpenGL should just
work fine (it does for me), but gives above sever side output.

As for Venus, for me I can run vulkaninfo just fine, and for vkcube I
get a client side error, complete client side output is:

  1 physical devices
  vendor id 1002, device name Virtio-GPU Venus (AMD Radeon RX 6700 XT 
  vkcube: ../src/virtio/vulkan/vn_queue.c:164:
   Assertion `!submit->wsi_mem->base_memory && submit->wsi_mem-
>base_bo' failed.

(The same assertion is triggered on Intel)

You can also try these server side options: 

   --no-fork and --multi-client

They make no difference for me, I just know that at the beginning they
were needed. 

Hope that helps, 

More information about the mesa-dev mailing list