<div dir="ltr">Hi Eric,<div><br></div><div>Sorry for the typo in commit message.</div><div><br></div><div>I made two separate patches as one was for mesa and other for gallium it has nothing to do with the use of "f" and "F". Regarding replacing the "F" with "f", maybe someone can shed some light as to why "F" was used specifically.</div><div><br></div><div>Regards,</div><div>Nayan. </div></div><div class="gmail_extra"><br><div class="gmail_quote">On Wed, Jun 15, 2016 at 6:32 PM, Eric Engestrom <span dir="ltr"><<a href="mailto:eric.engestrom@imgtec.com" target="_blank">eric.engestrom@imgtec.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div class="HOEnZb"><div class="h5">On Wed, Jun 15, 2016 at 03:38:05PM +0530, Nayan Deshmukh wrote:<br>
> Signed-off-by: Nayan Deshmukh <<a href="mailto:nayan26deshmukh@gmail.com">nayan26deshmukh@gmail.com</a>><br>
> ---<br>
> src/mesa/drivers/dri/r200/r200_swtcl.c | 6 +++---<br>
> 1 file changed, 3 insertions(+), 3 deletions(-)<br>
><br>
> diff --git a/src/mesa/drivers/dri/r200/r200_swtcl.c b/src/mesa/drivers/dri/r200/r200_swtcl.c<br>
> index 72f09ae..d3fb37f 100644<br>
> --- a/src/mesa/drivers/dri/r200/r200_swtcl.c<br>
> +++ b/src/mesa/drivers/dri/r200/r200_swtcl.c<br>
> @@ -835,9 +835,9 @@ r200PointsBitmap( struct gl_context *ctx, GLint px, GLint py,<br>
> else<br>
> f = _swrast_z_to_fogfactor(ctx, ctx->Current.RasterDistance);<br>
><br>
> - color[0] = f * rc[0] + (1.F - f) * fc[0];<br>
> - color[1] = f * rc[1] + (1.F - f) * fc[1];<br>
> - color[2] = f * rc[2] + (1.F - f) * fc[2];<br>
> + color[0] = f * rc[0] + (1.0F - f) * fc[0];<br>
> + color[1] = f * rc[1] + (1.0F - f) * fc[1];<br>
> + color[2] = f * rc[2] + (1.0F - f) * fc[2];<br>
> color[3] = rc[3];<br>
><br>
> UNCLAMPED_FLOAT_TO_CHAN(vert.tv.color.red, color[0]);<br>
> --<br>
> 2.5.5<br>
<br>
</div></div>Commit title has a typo: s/0.F/1.0F/<br>
<br>
And the only difference between the commits is the case of the "f",<br>
not sure it warrants being its own commit for that.<br>
IMHO you could even replace those `1.0F` with `1.0f`, unless this was<br>
done as some attempt to distinguish from `f`, in which case it would<br>
probably be better to just rename `f` to `factor` instead.<br>
But that's a different topic.<br>
</blockquote></div><br></div>