<div dir="ltr">Hi Gwan-yeong,<div><br></div><div>I'm fine with the conventions you suggested -- my main nit was with the verbosity.  The downside is you're going to have to downcast every single time.  Your call ..</div></div><div class="gmail_extra"><br><div class="gmail_quote">On Mon, Oct 23, 2017 at 1:22 PM, Mun, Gwan-gyeong <span dir="ltr"><<a href="mailto:elongbug@gmail.com" target="_blank">elongbug@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Hi Emil and Gurchetan,<br>
<br>
Thank you for  reviewing the patches.<br>
<span class=""><br>
2017-10-20 6:18 GMT+09:00 Gurchetan Singh <<a href="mailto:gurchetansingh@chromium.org">gurchetansingh@chromium.org</a>>:<br>
> De-duplicating and then trimming down works for me.<br>
><br>
> On Thu, Oct 19, 2017 at 3:31 AM, Emil Velikov <<a href="mailto:emil.l.velikov@gmail.com">emil.l.velikov@gmail.com</a>><br>
> wrote:<br>
>><br>
>> On 18 October 2017 at 23:36, Gurchetan Singh<br>
>> <<a href="mailto:gurchetansingh@chromium.org">gurchetansingh@chromium.org</a>> wrote:<br>
>> >> Then again, I'd suggest keeping that as separate series. These patches<br>
>> >> started as a way to minimise the duplication we have in drivers/dri2.<br>
>> ><br>
>> > I'm fine with dri2_$action_$object.  We can modify the existing<br>
>> > functions<br>
>> > later, but I recommend adopting more concise conventions in this<br>
>> > patchset,<br>
>> > i.e:<br>
>> ><br>
>> > dri2_egl_surface_record_<wbr>buffers_and_update_back_buffer --><br>
>> > dri2_set_back_buffer_surface<br>
>> > dri2_egl_surface_free_<wbr>outdated_buffers_and_update_<wbr>size --><br>
>> > dri2_fixup_surface<br>
>> > dri2_egl_surface_update_<wbr>buffer_age --> dri2_update_age_surface<br>
>> > dri2_egl_surface_get_image_<wbr>front --> dri2_get_front_image_surface<br>
>> ><br>
>> Sure thing, let's use consistent names with this series.<br>
>><br>
<br>
</span>It seems great with your suggested helper function names.<br>
<br>
nevertheless, egl/driver/dri3/ codes also use such as<br>
dri2_surface_$action_$object naming conventions.<br>
<br>
(ie.<br>
  __DRIdrawable *dri2_surface_get_dri_<wbr>drawable(_EGLSurface *surf)<br>
  void dri2_surface_set_out_fence_fd(<wbr>_EGLSurface *surf, int fence_fd)<br>
)<br>
<br>
If you are fine with dri2_surface_$action_$object naming convention, I<br>
suggest these function prototype.<br>
These have dri2_surface_$action_$object naming convention and change<br>
type of first argument.<br>
 (struct dri2_egl_surface => _EGLSurface )<br>
<br>
ie.<br>
  void dri2_egl_surface_record_<wbr>buffers_and_update_back_<wbr>buffer(struct<br>
dri2_egl_surface *dri2_surf, void *buffer)<br>
   => void dri2_surface_set_back_buffer(_<wbr>EGLSurface *surf, void *buffer)<br>
<br>
  void dri2_egl_surface_free_<wbr>outdated_buffers_and_update_<wbr>size(struct<br>
dri2_egl_surface *dri2_surf, int width, int height)<br>
   => void dri2_surface_fixup(_EGLSurface *surf, int width, int height)<br>
<br>
  void dri2_egl_surface_update_<wbr>buffer_age(struct dri2_egl_surface *dri2_surf)<br>
   => void dri2_surface_update_age(_<wbr>EGLSurface *surf)<br>
<br>
  int dri2_egl_surface_get_image_<wbr>front(struct dri2_egl_surface<br>
*dri2_surf, unsigned int format)<br>
   => int dri2_surface_get_front_image(_<wbr>EGLSurface *surf, unsigned int format)<br>
<br>
<br>
What do you think about this?<br>
<br>
Thanks,<br>
<br>
Gwan-gyeong.<br>
</blockquote></div><br></div>