<base href="https://bugs.freedesktop.org/">
    <body><table border="1" cellspacing="0" cellpadding="8">
          <th>Bug ID</th>
          <td><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - Build problem: meson build can not find wayland-scanner"

          <td>Build problem: meson build can not find wayland-scanner











          <td>mesa-dev@lists.freedesktop.org, shevegen@gmail.com

          <th>Depends on</th>
        <pre>+++ This bug was initially created as a clone of <a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - Build problem: meson build can not find wayland-scanner"
   href="show_bug.cgi?id=111126">Bug #111126</a> +++

I am trying to compile mesa 19.1.2 from source.

Meson version is: 0.51.1

Here is the log so far:

Version: 0.51.1
Source dir: /Depot/Temp/rbt/mesa-19.1.2
Build dir: /Depot/Temp/rbt/mesa-19.1.2/BUILD_DIRECTORY
Build type: native build
Program python found: YES (/System/Index/bin/python)
Project name: mesa
Project version: 19.1.2
Appending CFLAGS from environment: '-O2 -fPIC -fno-strict-overflow -Wno-error'
C compiler for the build machine: ccache cc (gcc 9.1.0 "cc (GCC) 9.1.0")
C++ compiler for the build machine: ccache c++ (gcc 9.1.0 "c++ (GCC) 9.1.0")
Appending CFLAGS from environment: '-O2 -fPIC -fno-strict-overflow -Wno-error'
C compiler for the host machine: ccache cc (gcc 9.1.0 "cc (GCC) 9.1.0")
C++ compiler for the host machine: ccache c++ (gcc 9.1.0 "c++ (GCC) 9.1.0")
Build machine cpu family: x86_64
Build machine cpu: x86_64
Program pkg-config found: YES (/System/Index/bin/pkg-config)
Found pkg-config: /System/Index/bin/pkg-config (0.29.2)
Run-time dependency vdpau found: YES 1.2
Run-time dependency xvmc found: YES 1.0.11
Found CMake: /System/Index/bin/cmake (3.14.5)
Run-time dependency libomxil-bellagio found: NO (tried pkgconfig and cmake)
Run-time dependency libtizonia found: NO (tried pkgconfig and cmake)
Run-time dependency libtizplatform found: NO (tried pkgconfig and cmake)
Run-time dependency tizilheaders found: NO (tried pkgconfig and cmake)
Run-time dependency libva found: YES 1.5.0
WARNING: Project targetting '>= 0.45' but tried to use feature introduced in
'0.46.0': Python Module
Program python3 found: YES (/System/Index/bin/python3)
Checking for function "bswap32" : YES 
Checking for function "bswap64" : YES 
Checking for function "clz" : YES 
Checking for function "clzll" : YES 
Checking for function "ctz" : YES 
Checking for function "expect" : YES 
Checking for function "ffs" : YES 
Checking for function "ffsll" : YES 
Checking for function "popcount" : YES 
Checking for function "popcountll" : YES 
Checking for function "unreachable" : YES 
Checking if "__attribute__((const))" compiles: YES 
Checking if "__attribute__((flatten))" compiles: YES 
Checking if "__attribute__((malloc))" compiles: YES 
Checking if "__attribute__((pure))" compiles: YES 
Checking if "__attribute__((unused))" compiles: YES 
Checking if "__attribute__((warn_unused_result))" compiles: YES 
Checking if "__attribute__((weak))" compiles: YES 
Checking if "__attribute__((format(...)))" compiles: YES 
Checking if "__attribute__((packed))" compiles: YES 
Checking if "__attribute__((returns_nonnull))" compiles: YES 
Checking if "__attribute__((visibility(...)))" compiles: YES 
Checking if "__attribute__((alias(...)))" compiles: YES 
Checking if "__attribute__((__noreturn__))" compiles: YES 
Compiler for C supports arguments -Werror=implicit-function-declaration: YES 
Compiler for C supports arguments -Werror=missing-prototypes: YES 
Compiler for C supports arguments -Werror=return-type: YES 
Compiler for C supports arguments -Werror=incompatible-pointer-types: YES 
Compiler for C supports arguments -fno-math-errno: YES 
Compiler for C supports arguments -fno-trapping-math: YES 
Compiler for C supports arguments -Qunused-arguments: NO 
Compiler for C supports arguments -Wmissing-field-initializers: YES 
Compiler for C supports arguments -Wformat-truncation: YES 
Compiler for C supports arguments -fvisibility=hidden: YES 
Compiler for C++ supports arguments -Werror=return-type: YES 
Compiler for C++ supports arguments -fno-math-errno: YES 
Compiler for C++ supports arguments -fno-trapping-math: YES 
Compiler for C++ supports arguments -Qunused-arguments: NO 
Compiler for C++ supports arguments -Wnon-virtual-dtor: YES 
Compiler for C++ supports arguments -Wmissing-field-initializers: YES 
Compiler for C++ supports arguments -Wformat-truncation: YES 
Compiler for C supports arguments -Woverride-init: YES 
Compiler for C supports arguments -Winitializer-overrides: NO 
Compiler for C++ supports arguments -fvisibility=hidden: YES 
Compiler for C supports arguments -Werror=pointer-arith: YES 
Compiler for C++ supports arguments -Werror=pointer-arith: YES 
Compiler for C supports arguments -Werror=vla: YES 
Compiler for C++ supports arguments -Werror=vla: YES 
Checking if "GCC atomic builtins" compiles: YES 
Checking if "GCC atomic builtins required -latomic" links: YES 
Checking if "GCC 64bit atomics" with dependency not-found links: YES 
Header <sys/sysmacros.h> has symbol "major" : YES 
Checking if "xlocale.h" compiles: NO 
Checking if "sys/sysctl.h" compiles: YES 
Checking if "linux/futex.h" compiles: YES 
Checking if "endian.h" compiles: YES 
Checking if "dlfcn.h" compiles: YES 
Checking if "execinfo.h" compiles: YES 
Checking for function "strtof" : YES 
Checking for function "mkostemp" : YES 
Checking for function "posix_memalign" : YES 
Checking for function "timespec_get" : YES 
Checking for function "memfd_create" : YES 
Checking if "strtod has locale support" links: YES 
Checking if "Bsymbolic" links: YES 
Checking if "gc-sections" links: YES 
Checking if "version-script" links: YES 
Checking if "dynamic-list" links: YES 
Checking for function "dlopen" : NO 
Library dl found: YES
Checking for function "dladdr" with dependency -ldl: YES 
Checking for function "dl_iterate_phdr" : YES 
Checking for function "clock_gettime" : YES 
Run-time dependency zlib found: YES 1.2.11
Run-time dependency threads found: YES 
Checking for function "pthread_setaffinity_np" with dependency threads: YES 
Run-time dependency expat found: YES 2.2.6
Library m found: YES
Message: libdrm 2.4.97 needed because amdgpu has the highest requirement
Run-time dependency libdrm_intel found: YES 2.4.99
Run-time dependency libdrm_amdgpu found: YES 2.4.99
Run-time dependency libdrm_radeon found: YES 2.4.99
Run-time dependency libdrm_nouveau found: YES 2.4.99
Run-time dependency libdrm found: YES 2.4.99
llvm-config found: YES (/System/Index/bin/llvm-config) 8.0.0
Run-time dependency LLVM (modules: amdgpu, asmparser, bitreader, bitwriter,
engine, ipo, mcdisassembler, mcjit, native) found: YES 8.0.0
Run-time dependency libelf found: YES 0.176
Run-time dependency valgrind found: NO (tried pkgconfig)
Program bison found: YES (/System/Index/bin/bison)
Program flex found: YES (/System/Index/bin/flex)
Run-time dependency libunwind found: YES 1.3.1
Found pkg-config: /System/Index/bin/pkg-config (0.29.2)
Found CMake: /System/Index/bin/cmake (3.14.5)
Build-time dependency wayland-scanner found: NO (tried pkgconfig and cmake)

meson.build:1361:2: ERROR: Dependency "wayland-scanner" not found, tried
pkgconfig and cmake

A full log can be found at


meson can not find wayland scanner, but it is right at

Additionally all the .pc files of wayland reside at /usr/lib/pkgconfig/.

Note that I have wayland installed via appdir-prefix at
and then use symlinks (similar to what the program called stow does).

llvm on the other hand is installed into the prefix /usr/.

I am not sure why the meson build can find cmake and pkg-config without a
problem, but not wayland-scanner.

cmake version is: 3.14.5

Content of wayland-scanner.pc is:


Name: Wayland Scanner
Description: Wayland scanner
Version: 1.17.0

I think there may be something failing but it is not stating why. If
possible it may be useful to have meson report a bit more to the
user in such an event, because "stat /usr/bin/wayland-scanner" works
fine, and the .pc file is there too, so I have no idea why meson
can not find it.</pre>

        <div id="referenced">
          <hr style="border: 1px dashed #969696">
          <b>Referenced Bugs:</b>
                [<a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - Build problem: meson build can not find wayland-scanner"
   href="https://bugs.freedesktop.org/show_bug.cgi?id=111126">Bug 111126</a>] Build problem: meson build can not find wayland-scanner

      <span>You are receiving this mail because:</span>

          <li>You are on the CC list for the bug.</li>