[PATCH] huawei: implement modem power up and down

Aleksander Morgado aleksander at lanedo.com
Fri Aug 2 08:49:06 PDT 2013

On 02/08/13 16:33, Dan Williams wrote:
> On Thu, 2013-08-01 at 21:44 -0700, Ben Chan wrote:
>> From: Franko Fang <fangxiaozhi at huawei.com>
>> This patch is originally developed by:
>>   Franko Fang <fangxiaozhi at huawei.com>
>> And then reviewed and updated by:
>>   Ben Chan <benchan at chromium.org>
> I was going to say, why doesn't the plugin check ^RFSWITCH as part of
> the the load_power_state() class method on the Modem interface?  That
> would reduce the code duplication in the power up and power down phases,
> and streamline the code so that it doesn't call back into the up or down
> bits from the same function.  Also gets rid of the context bits for
> checking the state.

Indeed, that's the best place to do that actually, as load_power_state()
is always run before allowing to power_down() or power_up().


More information about the ModemManager-devel mailing list