[PATCH] huawei: implement modem power up and down
benchan at chromium.org
Mon Aug 5 08:12:33 PDT 2013
Hi Aleksander and Dan,
Confirmed with Franko, he recommended using ^RFSWITCH=0/1 to turn off/on
the RF for modems that supports this command, and using +CFUN=0/1 as a
fallback. The latter is supported on those modems.
Could you review my revised patch and see if there is any other issue?
On Fri, Aug 2, 2013 at 6:10 PM, Ben Chan <benchan at chromium.org> wrote:
> Hi Aleksander and Dan,
> Thanks for the feedback. I rewrote the patch a bit to do the rfswitch
> check in load_power_state as you suggested. I tested the patch on a modem
> that supports RFSWITCH and one doesn't.
> I'll check with Franko regarding using +CFUN=0 vs +CFUN=4 in the fallback
> On Fri, Aug 2, 2013 at 8:49 AM, Aleksander Morgado <aleksander at lanedo.com>wrote:
>> On 02/08/13 16:33, Dan Williams wrote:
>> > On Thu, 2013-08-01 at 21:44 -0700, Ben Chan wrote:
>> >> From: Franko Fang <fangxiaozhi at huawei.com>
>> >> This patch is originally developed by:
>> >> Franko Fang <fangxiaozhi at huawei.com>
>> >> And then reviewed and updated by:
>> >> Ben Chan <benchan at chromium.org>
>> > I was going to say, why doesn't the plugin check ^RFSWITCH as part of
>> > the the load_power_state() class method on the Modem interface? That
>> > would reduce the code duplication in the power up and power down phases,
>> > and streamline the code so that it doesn't call back into the up or down
>> > bits from the same function. Also gets rid of the context bits for
>> > checking the state.
>> Indeed, that's the best place to do that actually, as load_power_state()
>> is always run before allowing to power_down() or power_up().
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the ModemManager-devel