MC7710 "forgetting" RAT

Aleksander Morgado aleksander at
Tue Feb 4 03:04:16 PST 2014


On Tue, Feb 4, 2014 at 11:52 AM, Martin Anderseck
<Martin.Anderseck at> wrote:
> Aleksander Morgado <aleksander at> wrote on 04.02.2014
> 09:41:10:
>> Weird, it keeps saying "registration_state =
>> 'not-registered-searching'". Can you run "mmcli -m 0 --3gpp-scan"?
> -> error: couldn't scan networks in the modem: 'Zeitüberschreitung wurde
> erreicht'
> (timeout was reached)

Oops, yeah, you should have used --timeout=300 or so in the mmcli
call, otherwise it will stop after 30s by default.

> In the second trial it lists me 10 networks. This 'Zeitüberschreitung
> wurde erreicht' is also the error that I get after simple-connect.

Yeah, use --timeout=300 when using mmcli, as said earlier.

> I tried the --set-allowed-modes and --set-current-bands flags for mmcli
> which you mentioned in your first reply. With the latter one I can set
> "any". For other bands I get a QMI protocol error (25):
> 'DeviceUnsupported'

Long time since I last tried setting up bands, so not sure what's the
status about that. Actually, last time I tried I bricked my UML290 and
now it's in some weird state...

> With --set-allowed-modes=3G or 4G it tells me
> error: couldn't set current modes:
> 'GDBus.Error:org.freedesktop.ModemManager1.Error.Core.Unsupported: Cannot
> change modes: only one combination supported'

You need to check which are the supported Mode combinations that you
currently have, in the "mmcli -m 0" output. In QMI devices, we have to
play with both Capabilities and Modes to change between different

E.g. if you have Capabilities=Lte, you will only be able to set Modes=4g
And if you have Capabilities=Gsm+Umts+Lte, you can likely set e.g.
Modes=2G+3G+4G and Preferred=4g

You should also be able to change Capabilities, to one of the ones
reported in the "mmcli -m 0".

Allowing to change both Capabilities and Modes lets us play with
multimode devices like the UML290, which can do all

> Should resetting via mmcli -m 0 -r be supported for the MC7710? It tells
> me that it isn't :-S

Not really; QMI devices don't handle that. You can do a factory reset
if you know the Service Programming Code, though.

> Are these things that might work --with-newest-qmi?

Nope. Newest QMI commands support other newer commands, but mainly for
NAS (e.g. signal quality retrieval and things like that). But I'd
suggest not to use that compile option, I don't think I've tested it

> Unfortunately this problem doesn't look quite systematic (yet). Did you
> see a similar behaviour with the MC7710 and did you use the 3.5.24
> firmware?

My MC7710 has revision; don't think I've seen that issue
in this version.

Can you run "qmicli -d /dev/cdc-wdm0 --get-service-version-info" and
get which are the QMI service versions supported in your firmware? I
wouldn't mind a NAS version newer than 1.21, which is the last one I


More information about the ModemManager-devel mailing list