MC7710 "forgetting" RAT

Martin Anderseck Martin.Anderseck at
Wed Feb 5 03:56:20 PST 2014


I did some more testing and it looks like I found a systematic behaviour: 
- I boot the system and check the RAT value using AT commands, it looks 
- I start ModemManager in one terminal and wait until the modem is 
- I use a second terminal to perform a mmcli --simple-connect
  => Exactly here it hangs, it won't connect.

If I quit ModemManager then and check the RAT value on the AT port again I 
get the invalid value. 

As you've said that you don't set anything related to the RAT within 
simple-connect I can only guess that the firmware doesn't understand 
something it receives in that process, right?


Aleksander Morgado <aleksander at> wrote on 04.02.2014 

> From: Aleksander Morgado <aleksander at>
> To: Martin Anderseck <Martin.Anderseck at>, 
> Cc: "ModemManager (development)" 
<modemmanager-devel at>
> Date: 04.02.2014 12:04
> Subject: Re: MC7710 "forgetting" RAT
> Hey,
> On Tue, Feb 4, 2014 at 11:52 AM, Martin Anderseck
> <Martin.Anderseck at> wrote:
> > Aleksander Morgado <aleksander at> wrote on 04.02.2014
> > 09:41:10:
> >> Weird, it keeps saying "registration_state =
> >> 'not-registered-searching'". Can you run "mmcli -m 0 --3gpp-scan"?
> >
> > -> error: couldn't scan networks in the modem: 'Zeitüberschreitung 
> > erreicht'
> > (timeout was reached)
> >
> Oops, yeah, you should have used --timeout=300 or so in the mmcli
> call, otherwise it will stop after 30s by default.
> > In the second trial it lists me 10 networks. This 'Zeitüberschreitung
> > wurde erreicht' is also the error that I get after simple-connect.
> >
> Yeah, use --timeout=300 when using mmcli, as said earlier.
> > I tried the --set-allowed-modes and --set-current-bands flags for 
> > which you mentioned in your first reply. With the latter one I can set
> > "any". For other bands I get a QMI protocol error (25):
> > 'DeviceUnsupported'
> Long time since I last tried setting up bands, so not sure what's the
> status about that. Actually, last time I tried I bricked my UML290 and
> now it's in some weird state...
> > With --set-allowed-modes=3G or 4G it tells me
> > error: couldn't set current modes:
> > 'GDBus.Error:org.freedesktop.ModemManager1.Error.Core.Unsupported: 
> > change modes: only one combination supported'
> >
> You need to check which are the supported Mode combinations that you
> currently have, in the "mmcli -m 0" output. In QMI devices, we have to
> play with both Capabilities and Modes to change between different
> ones.
> E.g. if you have Capabilities=Lte, you will only be able to set Modes=4g
> And if you have Capabilities=Gsm+Umts+Lte, you can likely set e.g.
> Modes=2G+3G+4G and Preferred=4g
> You should also be able to change Capabilities, to one of the ones
> reported in the "mmcli -m 0".
> Allowing to change both Capabilities and Modes lets us play with
> multimode devices like the UML290, which can do all
> > Should resetting via mmcli -m 0 -r be supported for the MC7710? It 
> > me that it isn't :-S
> Not really; QMI devices don't handle that. You can do a factory reset
> if you know the Service Programming Code, though.
> > Are these things that might work --with-newest-qmi?
> >
> Nope. Newest QMI commands support other newer commands, but mainly for
> NAS (e.g. signal quality retrieval and things like that). But I'd
> suggest not to use that compile option, I don't think I've tested it
> enough.
> > Unfortunately this problem doesn't look quite systematic (yet). Did 
> > see a similar behaviour with the MC7710 and did you use the 3.5.24
> > firmware?
> >
> My MC7710 has revision; don't think I've seen that issue
> in this version.
> Can you run "qmicli -d /dev/cdc-wdm0 --get-service-version-info" and
> get which are the QMI service versions supported in your firmware? I
> wouldn't mind a NAS version newer than 1.21, which is the last one I
> have.
> -- 
> Aleksander

National Instruments Dresden GmbH; Geschäftsführer (Managing Directors): Dr. Tim Hentschel, Dr. Thorsten Dräger; Sitz (Registered Office): Dresden; HRB (Commercial Register No.): 22081; Registergericht (Registration Court): Dresden

This email and any attachments are intended only for the person to whom this email is addressed and may contain confidential and/or privileged information. If you received this email in error, please do not disclose the contents to anyone, but notify the sender by return email and delete this email (and any attachments) from your system.

More information about the ModemManager-devel mailing list