Huawei modem (12d1:1573) resets with AT^GETPORTMODE

Aleksander Morgado aleksander at
Mon Mar 3 00:53:42 PST 2014


>> Just tried out a new modem module from Huawei (12d1:1573) and it seems get
>> quite upset with the AT^GETPORTMODE command.  Without modem manager running
>> I can issue this command on any of the suitable tty ports and the modem will
>> HW reset after 15 seconds or so.
>> Here is a patch that disables the command on this modem,  not sure if this
>> is the best way to do it so happy to be pointed in the right direction.
> So looks like the correct method for doing this is needed :-)
> The patch below is causing me crashes on a different Huawei modem.  It dies
> in "mm_device_get_product" because either self is invalid or self->priv is
> corrupted.
> Sorry for the bad patch, any help to create a correct fix appreciated :-)
> Thanks,
> Davidm
>> diff --git a/plugins/huawei/mm-plugin-huawei.c b/plugins/huawei/mm-plugin-huawei.c
>> index 89fe0fc..23cd4eb 100644
>> --- a/plugins/huawei/mm-plugin-huawei.c
>> +++ b/plugins/huawei/mm-plugin-huawei.c
>> @@ -285,6 +285,12 @@ huawei_custom_init_step (HuaweiCustomInitContext *ctx)
>>          return;
>>      }
>> +     /* this particular modem crashes/resets if you run AT^GETPORTMODE */
>> +     if (mm_device_get_product (mm_port_get_device (MM_PORT (ctx->port))) == 0x1573) {
>> +             ctx->getportmode_done = TRUE;
>> +             ctx->getportmode_retries = 0;
>> +     }
>> +
>>      /* Try to get a port map from the modem */
>>      if (!ctx->getportmode_done) {
>>          if (ctx->getportmode_retries == 0) {

What's the model name? I've got a Huawei ME906 which shows up with
that VID/PID pair, firmware revision, and I haven't
seen that behaviour myself. Have you tried to install the latest

How many ttys does this modem export? Does it also export a wwan iface?

If we really have to handle this case, we should setup a new udev tag;
e.g. ID_MM_HUAWEI_NO_PORTMODE, and just initialize
ctx->getportmode_retries=0 if the tag is found. This would allow us to
just add a new udev rule to handle new devices showing the same
symptom, instead of requiring to rebuild the Huawei plugin. But first,
I would like to confirm that the issue is not a firmware error which
is already fixed in newer firmware.


More information about the ModemManager-devel mailing list