Sierra Wireless EM7455

Bjørn Mork bjorn at
Wed Jun 1 08:31:17 UTC 2016

Ralph Plawetzki <ralph at> writes:

> Hi Bjørn,
> thanks for your quick reply!
> A long shot sounds good :)
> Am 01.06.2016 um 09:25 schrieb Bjørn Mork:
>> So that looks good.  It returns NoEffect, but I assume that is because
>> you've already sent the command.
> Ok.
>> Resetting MC7455 ... ok
> Thanks for the exact directions!
> [root at six tmp]# ./usbreset 1199:9079
> Resetting Sierra Wireless EM7455 Qualcomm Snapdragon X7 LTE-A ... ok
> [root at six tmp]#
> That looks good.
>> you will have to reconnect.  Does it make any difference?
> I tried to connect via network manager right away. First time without
> issueing a --dms-set-fcc-authentication first, this leads to an unknown
> error
> After that I issued the --dms-set-fcc-authentication
> ( and tried to connect again with the same
> unknown error

That's unexpected. This isn't going to be easy :(

Wild guessing now. Maybe the network/modem/MM don't like that you didn't
disconnect first?  You could try a full reset, followed by the same USB
reset and *then* fcc-auth + connect.  But I don't know what you have to
do to achieve a full modem reset.  Maybe "mmcli -m X -r" (replacing X
with the modem index) will do?  Or maybe you can do it with rfkill?  Or
maybe you have to reboot the laptop?

In any case, the theory is:
 1. Get the modem into a clean initial state
 2. USB reset
 3. FCC auth
 4. connect


More information about the ModemManager-devel mailing list