Fibocom L850-GL hangs upon connect.

Aleksander Morgado aleksander at
Thu Aug 16 09:18:10 UTC 2018

>>> If this modem is going to end up stuck with pure PPP and therefore maxing
>>> out at 25Mbps, then I'm not too concerned anyways since its use is rather
>>> limited. I just wish I could figure out how to switch this thing to MBIM
>>> (Tried everything listed in the AT Command reference guide, including
>>> factory resets and defaults.).
>> Talked to Fibocom engineers and unfortunately that firmware version
>> you're using cannot do MBIM :/
> On the latest Lenovo X1/T580/T480, this modem is plugged on a
> PCIe-enabled M2 port and boots as a PCI device. It seems Linux isn't
> able to handle that. People tried to tape the PCIe pins to make it boot
> as USB, but it's then blacklisted in the BIOS. Maybe you have some hints
> on how to make this modem switch to USB after booting?
> I don't own one yet, so I cannot really help with the specifics.
> Relevant thread:

Fibocom engineers say there is no way to "switch" to USB after the
device has been booted in PCIe mode. Was told that Intel may be
already working on the PCIe support for these devices in the kernel,
but while that is not a reality, there seems to be absolutely no way
to handle the device in the Thinkpad running Linux, unless Lenovo
decides to add the corresponding USB vid:pid in the BIOS whitelist.


More information about the ModemManager-devel mailing list