EM9191 PCIe with CM4

Aleksander Morgado aleksandermj at chromium.org
Tue Oct 24 09:45:36 UTC 2023


> I’m using a Sierra EM9191(sdx55) with PCIe on a raspberry CM4.
> Until now I had a firmware based on openWRT21.02, for which Aleksander had tuned the MM1.18.2 and few drivers.
> It worked nicely but we bought a new lot of CM4 and I need to upgrade few files for it to boot (start4.elf and fixup.dat).
> Upgrading the gpu-firmware package of the bcm2711 did the trick but it seems to have a side effect because the modem can’t connect properly anymore.
> For every new attempt (through luci) it attach, register and fail to connect, leaving the modem in a disabled state.
> My first move was to try the ‘official’ new openwrt, with latest update and better support to my hardware.
> I had the same result with openwrt 23.05/MM1.20.6 and openwrt master/MM1.22
> If I delete my interface in luci, then recreate it, sometimes it connects but there is no downlink traffic.
> When I try manually to establish the connection, I have this return:
> # mmcli -m 0 -e
> successfully enabled the modem.
> #  mmcli -m 0 --simple-connect="apn="
> error: couldn't connect the modem: 'GDBus.Error:org.freedesktop.ModemManager1.Error.Core.Unsupported: Cannot disable multiplex support'
> I managed to make the MHI driver handle the modem but I’m struggling with MM, anyone has a clue of what’s going on?
> If you need more information or trace, just let me know.

Could you try adding "multiplex=requested" to your --simple-connect call?

That "cannot disable multiplex support" error happens when we detect
there is a data aggregation protocol configured in the port. Could you
post a full MM debug log to try to understand where that comes from?


More information about the ModemManager-devel mailing list