ModemManager does not find 5G Modem in Linux VM

Dominik Nille Dominik.Nille at
Tue May 28 17:27:36 UTC 2024

Good evening,

my name is Dominik Nille and I am currently trying to work with a 5G modem (Quectel RM520N-GL) to log into a cellular network.
I am able to connect the Modem when using Windows or a Raspberry Pi. But somehow my current system to set up a development environment does not work.

My setup:
I use a laptop with operating system:           Windows 10 Enterprise
To run Linux in a virtual machine I use:        Oracle Virtualbox
My Linux:                                                       Debian GNU/Linux 12 (Kernel Version: 6.1.0-20-amd64 (64-bit)
Version of ModemManager:                          1.20.4
Version of NetworkManager:                        1.42.4

I try to connect an Evaluation Board, named "RMU500EK 5G Development-Kit" ( ) with integrated antennas via USB. Therefore, I set an USB-Filter to connect USB devices from Quectel to the Linux VM automatically.
I've now tried Multiple of those Boards with multiple of 5G modems and I also updated the firmware of the different modems. I tried different power supplying methods. With different connectors and also different USB-cables. I don't think that the problem is a hardware setup problem, because I can run the modem without a problem on the windows host.

Investigating the problem in linux:

When I run lsusb following output is displayed:
Bus 002 Device 006: ID 2c7c:0801 Quectel Wireless Solutions Co., Ltd. RM520N-GL

When I run ls /dev, there are listed the 4 serial devices and 1 modem device.
cdc-wdm0, ttyUSB0, ttyUSB1, ttyUSB2, ttyUSB3

Previously, I used the NetworkManager in combination with the ModemManager to get a connection on the same setup to monitor my cellular connections. Maybe I updated some packages or changed something else on the system.
However, I am currently not able to access the Modem with the ModemManager, but I don't know the reason.

When I run mmcli -m any there is displayed the following output:
error: couldn't find modem

If I investigate the journalctl I see, that some outputs. The following are some main outputs:
<warn>  [plugin/quectel] could not grab port ttyUSB0: Cannot add port 'tty/ttyUSB0', unhandled port type
<warn>  [modem1] couldn't load carrier config: Operation timed out
<error> [modem1] port cdc-wdm0 timed out 25 consecutive times, marking modem as invalid
<warn>  [modem1] couldn't load hardware revision: QMI operation failed: Transaction timed out
<warn>  [modem1] couldn't load equipment identifier: QMI operation failed: Transaction timed out
<warn>  [modem1] couldn't load device identifier: Modem interface skeleton unavailable
<warn>  [modem1] couldn't load supported bands: Couldn't peek QMI port
<warn>  [modem1] couldn't load power state: Couldn't peek QMI port
<warn>  [modem1] couldn't load current allowed/preferred modes: Couldn't peek QMI port
<warn>  [modem1] couldn't load current bands: Couldn't peek QMI port
<warn>  [modem1] (quectel) failed to initialize SIM hot swap ports context: Couldn't get primary port
<warn>  [modem1] couldn't query SIM slots: Couldn't peek QMI port
<warn>  [modem1] modem couldn't be initialized: Couldn't check unlock status: Couldn't get interface skeleton
<warn>  [modem1] error initializing: Operation was cancelled

Do you have any Idea, why the ModemManager is not able to grab the serial port? This happens very often with multiple ports.
And do you have any idea, why the port cdc-wdm0 is timing out 25 consecutive times? Is there any present issue with bridging USB-Ports of Virtualbox maybe?

Maybe the given information is already enough for you, to see the problem.

If not, I investigated further:
I also ran the ModemManager in Debug mode and captured the output in a log.txt, which is attached. I just cut off some beginning when the ModemManager was dealing with ethernetports. I plugged in the Modem after starting it in debug mode. And the attached output were captured.

Thank you very much for your help.

Best regards,

Dominik Nille
Innovation Management


Balluff GmbH * Schurwaldstrasse 9 * 73765 Neuhausen a.d.F. * Germany
Phone +497158173-8020 * Fax +4971585010 * Dominik.Nille at<mailto:Dominik.Nille at> *<>

[Facebook]<>  [LinkedIn] <>   [Twitter] <>   [Youtube] <>   [Xing] <>   [Blog] <>

Place of incorporation/Sitz der Gesellschaft: Neuhausen a.d.F., Germany * Register court/Registergericht: Amtsgericht Stuttgart, Germany
Trade register/Handelsregister: HRB 214038 * Managing directors/Gesch?ftsf?hrer: Katrin Stegmaier-Hermle, Florian Hermle, Frank Nonnenmann
Chairman board of directors/Vorsitzender des Aufsichtsrats: Michael Unger * VAT ID/USt-ID: DE213 402 337

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: log.txt
URL: <>

More information about the ModemManager-devel mailing list