[Networkmanager] "device is strictly unmanaged"

Christian Schaubschläger christian.schaubschlaeger at gmx.at
Mon May 15 12:24:17 UTC 2023

Hello everyone,

I'm having a strange issue with an USB ethernet device (Realtek r8152) and NetworkManager (1.42.6, I've also tried older versions with the same result). I'm not experiencing this on a particular Linux distribution, but rather on a self-tailored Linux (based on Linux from Scratch), so it's probably a configuration issue, but unfortunately I'm really out of ideas what's wrong here.

So the thing is this: when I plug the mentioned USB dongle when the system is up and running, I cannot use it with NetworkManager, because eventually I always get the error

"Failed to activate 'eth1': Connection 'eth1' is not available on device eth1 because device is strictly unmanaged"

I've googled this error a lot but couldn't find anything that makes things work for me. One interesting thing is, that when I boot the system with the USB dongle connected, everything works as expected. Also, when I boot the system with the dongle disconnected, then plug it, then restart the NM daemon, it works fine, too.

I've attached the NetworkManager's logs from a representative session, where first the NM daemon starts, then I connect the dongle (eth1), and I then issue a "nmcli d connect eth1" command.
(Note: issuing "nmcli d set eth1 managed yes" prior to connecting doesn't help...)

Note2: on Ubuntu 22.04 everything works as expected...

Maybe somebody has an idea about what's going wrong here?
Thanks and best regards,
-------------- next part --------------
A non-text attachment was scrubbed...
Name: nm-strictly-unmanaged.log.bz2
Type: application/x-bzip
Size: 12087 bytes
Desc: not available
URL: <https://lists.freedesktop.org/archives/networkmanager/attachments/20230515/dea3ef37/attachment.bin>

More information about the Networkmanager mailing list