[Nouveau] [Bug 27706] New: Blank screen and "Error referencing VRAM ctxdma: -12" on NV44A with ubuntu lucid beta 2 (worked in alpha 3)

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Fri Apr 16 13:04:51 PDT 2010


           Summary: Blank screen and "Error referencing VRAM ctxdma: -12"
                    on NV44A with ubuntu lucid beta 2 (worked in alpha 3)
           Product: xorg
           Version: 7.5
          Platform: x86 (IA32)
        OS/Version: Linux (All)
            Status: NEW
          Severity: critical
          Priority: medium
         Component: Driver/nouveau
        AssignedTo: nouveau at lists.freedesktop.org
        ReportedBy: mossroy.mossroy at gmail.com
         QAContact: xorg-team at lists.x.org

Created an attachment (id=35110)
 --> (https://bugs.freedesktop.org/attachment.cgi?id=35110)
Dmesg on ubuntu lucid beta 2 installed (does not work)

I can't start the ubuntu lucid beta 2 liveCD on a computer with a Nvidia
GeForce 6200 (NV44A rev A1) : the screen stays blank after booting.
It works properly with a ubuntu lucid alpha 3 liveCD (which probably uses a
previous version of nouveau) and ubuntu karmic liveCD (which uses nv driver)

I managed to install the beta 2 on this computer through the alternate CD : the
behavior is the same when booting on the hard drive.
I installed all the updates (as of 16th april 2040) : same behavior

I experience the precise same behavior with Fedora live : Fedora 12 live boots
correctly (but relies on "nv" driver), Fedora 13 beta live gives the same blank
screen (and also uses "nouveau" driver).

I think this is a regression in the "nouveau" graphic driver : the version
bundled with lucid alpha 3 works, the one with lucid beta 2 (or fedora 13 beta)
does not.
Here is an excerpt of the dmesg on beta 2 :
  nouveau 0000:03:00.0: RAMHT space exhausted. ch=0
  nouveau 0000:03:00.0: Error referencing VRAM ctxdma: -12
  nouveau 0000:03:00.0: gpuobj -12

This error message does not appear when using lucid alpha 3.

I found that adding "nouveau.noaccel=1" as a boot parameter is a workaround,
both on ubuntu lucid beta 2 and on fedora 13 beta

My motherboard is a Asus A7N8X-E deluxe, on which a GeForce 6200 video card
(branded MSI) is in the AGP port.

You will find attached the dmesg of :
- ubuntu lucid beta 2 installed (does not work)
- ubuntu lucid alpha 3 liveCD (works)
- ubuntu lucid beta 2 installed, with nouveau.noaccel=1 (works)

lspci gives :
03:00.0 VGA compatible controller: nVidia Corporation NV44A [Geforce 6200] (rev

I first opened this bug on ubuntu launchpad :

Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the Nouveau mailing list