[Nouveau] [PATCH] drm/nv50: rename INVALID_QUERY_OR_TEXTURE error to INVALID_OPERATION
Ben Skeggs
skeggsb at gmail.com
Thu Jun 14 17:17:35 PDT 2012
On Thu, Jun 14, 2012 at 11:58:08PM +0200, Marcin Slusarz wrote:
> Current name is misleading, because this error can be triggered by other
> conditions, like changing STRMOUT parameter without disabling STRMOUT first.
>
Applied, thanks.
> Signed-off-by: Marcin Slusarz <marcin.slusarz at gmail.com>
> ---
> drivers/gpu/drm/nouveau/nv50_graph.c | 2 +-
> 1 files changed, 1 insertions(+), 1 deletions(-)
>
> diff --git a/drivers/gpu/drm/nouveau/nv50_graph.c b/drivers/gpu/drm/nouveau/nv50_graph.c
> index 0289a96..0fd1117 100644
> --- a/drivers/gpu/drm/nouveau/nv50_graph.c
> +++ b/drivers/gpu/drm/nouveau/nv50_graph.c
> @@ -299,7 +299,7 @@ static struct nouveau_bitfield nv50_graph_trap_ccache[] = {
>
> /* There must be a *lot* of these. Will take some time to gather them up. */
> struct nouveau_enum nv50_data_error_names[] = {
> - { 0x00000003, "INVALID_QUERY_OR_TEXTURE", NULL },
> + { 0x00000003, "INVALID_OPERATION", NULL },
> { 0x00000004, "INVALID_VALUE", NULL },
> { 0x00000005, "INVALID_ENUM", NULL },
> { 0x00000008, "INVALID_OBJECT", NULL },
> --
> 1.7.8.6
>
> _______________________________________________
> Nouveau mailing list
> Nouveau at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/nouveau
More information about the Nouveau
mailing list