[Nouveau] [Bug 84515] New: [NV96] HDMI audio works, but has audio gaps or pauses

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Tue Sep 30 08:36:05 PDT 2014


          Priority: medium
            Bug ID: 84515
          Assignee: nouveau at lists.freedesktop.org
           Summary: [NV96] HDMI audio works, but has audio gaps or pauses
        QA Contact: xorg-team at lists.x.org
          Severity: normal
    Classification: Unclassified
                OS: Linux (All)
          Reporter: ppaalanen at gmail.com
          Hardware: x86-64 (AMD64)
            Status: NEW
           Version: unspecified
         Component: Driver/nouveau
           Product: xorg

Created attachment 107133
  --> https://bugs.freedesktop.org/attachment.cgi?id=107133&action=edit
output of lspci -nn

I'm running 3.16.3-gentoo kernel with a
 nouveau  [  DEVICE][0000:01:00.0] BOOT0  : 0x096500a1
 nouveau  [  DEVICE][0000:01:00.0] Chipset: G96 (NV96)

On a whim, I decided to try HDMI audio. I plugged in the TV, and extended my
desktop there. To my surprise, 'alsamixer' reports "Card: HDA Intel" and "Chip:
Nvidia MCP77/78 HDMI".

In audacious' ALSA settings, I found a "PCM device" hw:0,3 labeled as "HDMI 0".
When I choose that as the output and play a song:

- The laptop internal speakers, i.e. the whole normal analog audio output
system, produces a loud static, which I have to mute in Alsamixer by muting

- The song comes out mostly fine on the TV! (Was this supposed to work??)

I found I can mute the HDMI audio in alsamixer by setting "S/PDIF" off. No
other control I tried has any effect on it. That is ok for me.

Apart from the static in the laptop speakers, the primary annoying problem is
that the HDMI audio has short gaps or pauses. I measured it by ear for a couple
of minutes, and the gaps occur roughly 33 second intervals. The length of a gap
is less than a second, maybe a half second.

This bug is about the gaps.

This is the same system as in my bug #60680 where we eventually got HDMI video
output regression solved. You can find an old mmiotrace there, and VBIOS dump.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/nouveau/attachments/20140930/aebcd936/attachment.html>

More information about the Nouveau mailing list