[Nouveau] [PATCH 2/6] debugfs: rename functions to indicate they are used inside drm
Karol Herbst
nouveau at karolherbst.de
Tue Oct 13 04:39:07 PDT 2015
we will need our own debugfs_init and cleanup functions, because nouveau_drm isn't ready while the drm ones are called by drm
Signed-off-by: Karol Herbst <nouveau at karolherbst.de>
---
drm/nouveau/nouveau_debugfs.c | 4 ++--
drm/nouveau/nouveau_debugfs.h | 9 +++++----
drm/nouveau/nouveau_drm.c | 4 ++--
3 files changed, 9 insertions(+), 8 deletions(-)
diff --git a/drm/nouveau/nouveau_debugfs.c b/drm/nouveau/nouveau_debugfs.c
index 762441f..3736796 100644
--- a/drm/nouveau/nouveau_debugfs.c
+++ b/drm/nouveau/nouveau_debugfs.c
@@ -86,7 +86,7 @@ nouveau_debugfs_create_file(struct drm_minor *minor,
}
int
-nouveau_debugfs_init(struct drm_minor *minor)
+nouveau_drm_debugfs_init(struct drm_minor *minor)
{
int i, ret;
@@ -102,7 +102,7 @@ nouveau_debugfs_init(struct drm_minor *minor)
}
void
-nouveau_debugfs_takedown(struct drm_minor *minor)
+nouveau_drm_debugfs_cleanup(struct drm_minor *minor)
{
int i;
diff --git a/drm/nouveau/nouveau_debugfs.h b/drm/nouveau/nouveau_debugfs.h
index a62af6f..42d65c9 100644
--- a/drm/nouveau/nouveau_debugfs.h
+++ b/drm/nouveau/nouveau_debugfs.h
@@ -4,16 +4,17 @@
#include <drm/drmP.h>
#if defined(CONFIG_DEBUG_FS)
-extern int nouveau_debugfs_init(struct drm_minor *);
-extern void nouveau_debugfs_takedown(struct drm_minor *);
+extern int nouveau_drm_debugfs_init(struct drm_minor *);
+extern void nouveau_drm_debugfs_cleanup(struct drm_minor *);
#else
static inline int
-nouveau_debugfs_init(struct drm_minor *minor)
+nouveau_drm_debugfs_init(struct drm_minor *minor)
{
return 0;
}
-static inline void nouveau_debugfs_takedown(struct drm_minor *minor)
+static inline void
+nouveau_drm_debugfs_cleanup(struct drm_minor *minor)
{
}
diff --git a/drm/nouveau/nouveau_drm.c b/drm/nouveau/nouveau_drm.c
index 189e591..3044dde 100644
--- a/drm/nouveau/nouveau_drm.c
+++ b/drm/nouveau/nouveau_drm.c
@@ -929,8 +929,8 @@ driver_stub = {
.lastclose = nouveau_vga_lastclose,
#if defined(CONFIG_DEBUG_FS)
- .debugfs_init = nouveau_debugfs_init,
- .debugfs_cleanup = nouveau_debugfs_takedown,
+ .debugfs_init = nouveau_drm_debugfs_init,
+ .debugfs_cleanup = nouveau_drm_debugfs_cleanup,
#endif
.get_vblank_counter = drm_vblank_count,
--
2.6.1
More information about the Nouveau
mailing list