[Nouveau] [PATCH v3 0/9] PCIEs speed change
Karol Herbst
nouveau at karolherbst.de
Tue Oct 13 17:44:28 PDT 2015
I hope now the final revison of that patch series.
I've taken care of 2 out of 3 comments from ben.
I left the set_link and set_version name this way, because I can't figure any
better name and because they are always used with pcie. in front, so they
should fit in nice
Ben: if you are strong about that, I can change that, but I really want better
names then.
Karol Herbst (9):
pci: add gk104 variant
pci: add gf106 variant
pci: implement generic code for PCIe speed change
pci: implement pcie speed change for tesla
pci: implement pcie speed change on Fermi
pci: implement PCIe speed change for kepler+
bios/perf: parse the pci speed from the bios for tesla and newer cards
perf: add fields for pci speed and width and use it for the pstates
perf: change pcie speed on pstate change
drm/nouveau/include/nvkm/subdev/bios/perf.h | 2 +
drm/nouveau/include/nvkm/subdev/clk.h | 3 +
drm/nouveau/include/nvkm/subdev/pci.h | 16 ++
drm/nouveau/nvkm/engine/device/base.c | 30 ++--
drm/nouveau/nvkm/subdev/bios/perf.c | 16 ++
drm/nouveau/nvkm/subdev/clk/base.c | 6 +
drm/nouveau/nvkm/subdev/pci/Kbuild | 3 +
drm/nouveau/nvkm/subdev/pci/base.c | 5 +
drm/nouveau/nvkm/subdev/pci/g84.c | 97 ++++++++++++
drm/nouveau/nvkm/subdev/pci/g94.c | 18 +++
drm/nouveau/nvkm/subdev/pci/gf100.c | 64 ++++++++
drm/nouveau/nvkm/subdev/pci/gf106.c | 48 ++++++
drm/nouveau/nvkm/subdev/pci/gk104.c | 229 ++++++++++++++++++++++++++++
drm/nouveau/nvkm/subdev/pci/pcie.c | 165 ++++++++++++++++++++
drm/nouveau/nvkm/subdev/pci/priv.h | 32 ++++
15 files changed, 719 insertions(+), 15 deletions(-)
create mode 100644 drm/nouveau/nvkm/subdev/pci/gf106.c
create mode 100644 drm/nouveau/nvkm/subdev/pci/gk104.c
create mode 100644 drm/nouveau/nvkm/subdev/pci/pcie.c
--
2.6.1
More information about the Nouveau
mailing list