[Nouveau] [PATCH v2 1/2] gpu: drm/lease:: Use list_{next/prev}_entry instead of list_entry
Daniel Vetter
daniel at ffwll.ch
Mon Mar 26 08:37:55 UTC 2018
On Sun, Mar 25, 2018 at 11:31:32PM +0530, Arushi Singhal wrote:
> It's better to use list_entry instead of list_{next/prev}_entry
> as it makes the code more clear to read.
> This patch replace list_entry with list_{next/prev}_entry.
>
> Signed-off-by: Arushi Singhal <arushisinghal19971997 at gmail.com>
Applied to drm-misc-next, thanks for your patch. I'll leave the other one
to nouveau folks.
-Daniel
> ---
> drivers/gpu/drm/drm_lease.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/drm_lease.c b/drivers/gpu/drm/drm_lease.c
> index 1402c0e..4dcfb5f 100644
> --- a/drivers/gpu/drm/drm_lease.c
> +++ b/drivers/gpu/drm/drm_lease.c
> @@ -340,7 +340,7 @@ static void _drm_lease_revoke(struct drm_master *top)
> break;
>
> /* Over */
> - master = list_entry(master->lessee_list.next, struct drm_master, lessee_list);
> + master = list_next_entry(master, lessee_list);
> }
> }
> }
> --
> 2.7.4
>
> _______________________________________________
> Nouveau mailing list
> Nouveau at lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/nouveau
--
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch
More information about the Nouveau
mailing list