[Nouveau] [PATCH] drm/nouveau/mmu: use struct_size() helper

Ben Skeggs skeggsb at gmail.com
Mon May 27 06:21:42 UTC 2019


On Sat, 25 May 2019 at 03:35, Gustavo A. R. Silva
<gustavo at embeddedor.com> wrote:
>
> Make use of the struct_size() helper instead of an open-coded version
> in order to avoid any potential type mistakes, in particular in the
> context in which this code is being used.
>
> So, replace the following form:
>
> sizeof(*kind) + sizeof(*kind->data) * mmu->kind_nr;
>
> with:
>
> struct_size(kind, data, mmu->kind_nr)
>
> This code was detected with the help of Coccinelle.
>
> Signed-off-by: Gustavo A. R. Silva <gustavo at embeddedor.com>
Thanks!

> ---
>  drivers/gpu/drm/nouveau/nvif/mmu.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/nouveau/nvif/mmu.c b/drivers/gpu/drm/nouveau/nvif/mmu.c
> index ae08a1ca8044..5641bda2046d 100644
> --- a/drivers/gpu/drm/nouveau/nvif/mmu.c
> +++ b/drivers/gpu/drm/nouveau/nvif/mmu.c
> @@ -110,7 +110,7 @@ nvif_mmu_init(struct nvif_object *parent, s32 oclass, struct nvif_mmu *mmu)
>
>         if (mmu->kind_nr) {
>                 struct nvif_mmu_kind_v0 *kind;
> -               u32 argc = sizeof(*kind) + sizeof(*kind->data) * mmu->kind_nr;
> +               size_t argc = struct_size(kind, data, mmu->kind_nr);
>
>                 if (ret = -ENOMEM, !(kind = kmalloc(argc, GFP_KERNEL)))
>                         goto done;
> --
> 2.21.0
>
> _______________________________________________
> Nouveau mailing list
> Nouveau at lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/nouveau


More information about the Nouveau mailing list