[PATCH v2] drm/nouveau: Improve variable names in nouveau_sched_init()
Danilo Krummrich
dakr at redhat.com
Fri Jul 12 17:38:54 UTC 2024
On 7/12/24 8:26 AM, Philipp Stanner wrote:
> nouveau_sched_init() uses the function drm_sched_init(). The latter
> function has parameters called "hang_limit" and "timeout" in its API
> documentation.
>
> nouveau_sched_init(), however, defines a variable called
> "job_hang_limit" which is passed to drm_sched_init()'s "timeout"
> parameter. The actual "hang_limit" parameter is directly set to 0.
>
> Rename "job_hang_limit" to "timeout".
>
> Signed-off-by: Philipp Stanner <pstanner at redhat.com>
Applied to drm-misc-next, thanks!
> ---
> Changes in v2:
> - Remove variable "hang_limit". (Danilo)
> ---
> drivers/gpu/drm/nouveau/nouveau_sched.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/gpu/drm/nouveau/nouveau_sched.c b/drivers/gpu/drm/nouveau/nouveau_sched.c
> index 32fa2e273965..ba4139288a6d 100644
> --- a/drivers/gpu/drm/nouveau/nouveau_sched.c
> +++ b/drivers/gpu/drm/nouveau/nouveau_sched.c
> @@ -404,7 +404,7 @@ nouveau_sched_init(struct nouveau_sched *sched, struct nouveau_drm *drm,
> {
> struct drm_gpu_scheduler *drm_sched = &sched->base;
> struct drm_sched_entity *entity = &sched->entity;
> - long job_hang_limit = msecs_to_jiffies(NOUVEAU_SCHED_JOB_TIMEOUT_MS);
> + const long timeout = msecs_to_jiffies(NOUVEAU_SCHED_JOB_TIMEOUT_MS);
> int ret;
>
> if (!wq) {
> @@ -418,7 +418,7 @@ nouveau_sched_init(struct nouveau_sched *sched, struct nouveau_drm *drm,
>
> ret = drm_sched_init(drm_sched, &nouveau_sched_ops, wq,
> NOUVEAU_SCHED_PRIORITY_COUNT,
> - credit_limit, 0, job_hang_limit,
> + credit_limit, 0, timeout,
> NULL, NULL, "nouveau_sched", drm->dev->dev);
> if (ret)
> goto fail_wq;
More information about the Nouveau
mailing list