[Openchrome-devel] segfault when playing video in fullscreen

Natanael Copa ncopa
Thu May 5 12:52:36 PDT 2011


I have an issue with mplayer and vlc and playing video in fullscreen on
my hp 2133. It crashes the X server.

I have xorg-server-1.10.1, pixman-0.22.0 and xf86-video-openchrome with
latest svn. I have tried last stable release 0.2.904, too with same

This used to work before but i don't remember if crashes happened after
pixman upgrade (happened with 0.20 too and i upgraded to see if that
solved anything). Everything else seems to work, xfce with composition,
firefox 4. mplayer works too - as long as i dont make it fullscreen.

I have tried disable EXA, composition, greedyheuristics etc but with
same result.

mplayer works just fine in fullscreen on a x86_64 box with
an ATI card and same combo of apps (also alpine linux with uclibc)

So i thought this is related the driver somehow.

I got this in log:
May  5 21:24:17 alpine-netbook kern.info kernel: [ 4593.544917]
X[2883]: segfault at 201 ip b749f252 sp bfdc9630 error 4 in
libpixman-1.so.0.22.0[b748e000+660 00]

So i rebuilt pixman, xorg-server and xf86-video-openchrome with
debugging symbols, set option NoTrapSignals in xorg.conf (normally an
xorg.conf is not needed nowdays...) and got a core dump.


Core was generated by `/usr/bin/X :0 vt07 -nolisten tcp'.
Program terminated with signal 11, Segmentation fault.
#0  0xb749f252 in ?? ()
(gdb) bt
#0  0xb749f252 in ?? ()
#1  0xb7441204 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

(I also find it interesting that SSP didn't catch this)

I have tried to attach gdb to the running process but that just hangs
Xorg for me.

I am an alpine linux which uses uclibc instead of glibc so I am
familiar with C, gdb and (non-xorg) bugs but this time i need some help.

Any hints on how I track this down?



PS. I have tried the recently announced xf86-video-chrome driver but it
insists on not finding my lcd screen. it works if i connect external
vga (crt) and lcd works too but without external screen Xorg just don't
start. I'd like to fix that too at some point.

More information about the Openchrome-devel mailing list