[Openchrome-devel] Is EXA composite working?

Daniel Drake dsd at laptop.org
Sat Jun 8 11:05:40 PDT 2013

On Wed, Jun 5, 2013 at 6:14 PM, James Simmons <jsimmons at infradead.org> wrote:
>> Just gave the latest git driver a quick spin on OLPC XO-1.5 (VX855)
>> now that EXA has been enabled again.
> Thanks for trying it. One other problem from our own testing on the XO
> is Xv seems to be broken.

This has been true for a while, but it did used to work, so hopefully
it will not be too hard to fix.

>> However, composite doesn't seem to be working. viaExaCheckComposite_H6
>> is called a lot, and returns TRUE in most cases, but the
>> PrepareComposite and Composite functions are never called (tested by
>> inserting ErrorF statements, nothing gets printed).
> Yipes!! I just assumed it worked since some time ago some patches went
> in that fixed compositing.

Could be something specific to my setup... it would be worth a quick
test at your end.

> P.S
>         In order for XO to use our org driver what is most needed.

Good question - I was also thinking about this subject, which is why I
tried the latest version.

1. EXA working

2. Basic Xv working

3. Screen rotation
See http://lists.freedesktop.org/archives/openchrome-devel/2012-August/000736.html
for the options
I was going to try the GECMD rotate bits
now, until I found that EXA wasn't being called.

Another option is using the 3d engine for rotation, as
xf86-video-chrome does. At a glance, I think it might be quite easy:
maybe it is just a case of transforming the coordinates sent to
emitQuad. See how viaAccelTexture3DBlt() (in via_3d.c in
xf86-video-chrome source) calls viaTransformCompute() before calling
emitQuad. That might be a good quick test to run. However, I am not
100% sure that I am looking at the right codepath.

4. Multiple Xv sufaces

This is implemented by xf86-video-chrome, I haven't looked into the details yet.

xf86-video-chrome source is


More information about the Openchrome-devel mailing list