Wow.<br>The new funtion version is much more simple and clean.<br><br>You don't need any commment to the function, because the name of the function is describing by ownself.<br>(the comment will only repeat what was already written in function name)<br><br>So every invocation of this function will be fully undestandable. <br><br>Nice catch.<br><br>Small nitpick: Screen_State variable is using underscore for word separation. In future it will be great to be consistent with the rest part of the code and separate it with camel case. So in that case it could be: ScreenState<br><br>Also what do you think about convention:<br>- variable names starts from small letter<br>- Type names starts from capital letter<br>?<br><br>Best Regards<br>Bartosz<br><br>W dniu wtorek, 26 kwietnia 2016 Luc Verhaegen <<a href="mailto:libv@skynet.be">libv@skynet.be</a>> napisał(a):<br>> On Tue, Apr 26, 2016 at 09:38:52AM -0700, Kevin Brace wrote:<br>>>  src/via_display.c |   24 ++++++++++++++++++++++++<br>>>  src/via_ums.h     |    1 +<br>>>  2 files changed, 25 insertions(+)<br>>><br>>> New commits:<br>>> commit 479b2ab119d05c22e1541f4cf25fe816419a86e9<br>>> Author: Kevin Brace <<a href="mailto:kevinbrace@gmx.com">kevinbrace@gmx.com</a>><br>>> Date:   Tue Apr 26 09:31:58 2016 -0700<br>>><br>>>     Turning off IGA2 correctly<br>>><br>>>     Added viaIGA2Screen function to via_display.c.<br>>><br>>>     Signed-off-by: Kevin Brace <<a href="mailto:kevinbrace@gmx.com">kevinbrace@gmx.com</a>><br>>><br>>> diff --git a/src/via_display.c b/src/via_display.c<br>>> index 0fe0c13..8dbfeea 100644<br>>> --- a/src/via_display.c<br>>> +++ b/src/via_display.c<br>>> @@ -49,6 +49,26 @@ viaIGA1DPMSControl(ScrnInfoPtr pScrn, CARD8 DPMS_Control)<br>>>  }<br>>><br>>>  /*<br>>> + * Controls IGA2 screen state.<br>>> + */<br>>> +void<br>>> +viaIGA2Screen(ScrnInfoPtr pScrn, Bool Screen_State)<br>>> +{<br>>> +    vgaHWPtr hwp = VGAHWPTR(pScrn);<br>>> +<br>>> +    DEBUG(xf86DrvMsg(pScrn->scrnIndex, X_INFO,<br>>> +                        "Entered viaIGA2Screen.\n"));<br>>> +<br>>> +    /* 3X5.6B[2]: IGA2 Screen Off<br>>> +     * 0 = Screen on<br>>> +     * 1 = Screen off */<br>>> +    ViaCrtcMask(hwp, 0x6B, Screen_State ? 0x00 : 0x04, 0x04);<br>><br>> I wrote the mask functions to aid readability.<br>><br>> By naming the variable "Screen_State" with a bool, you removed<br>> readability. If you had named it "Enabled", things would be clearer.<br>><br>> If you had called the function viaIGA2Enable, things would be<br>> clearer as well.<br>><br>> You would then not need to add a snippet of datasheet information.<br>><br>> Also, by using Mask, you improve readability several orders of<br>> magnitude, but by using the ? : construct, you remove readability.<br>><br>> This here<br>><br>> void<br>> viaIGA2Enable(ScrnInfoPtr pScrn, Bool Enable)<br>> {<br>>     vgaHWPtr hwp = VGAHWPTR(pScrn);<br>><br>>     DEBUG(xf86DrvMsg(pScrn->scrnIndex, X_INFO, "%s().\n", __FUNC__));<br>><br>>     if (Enable)<br>>         ViaCrtcMask(hwp, 0x6B, 0, 0x04);<br>>     else<br>>         ViaCrtcMask(hwp, 0x6B, 0x04, 0x04);<br>> }<br>><br>> requires absolutely no mental arithmetic and needs no comment.<br>><br>> Less is more.<br>><br>> Note that i am, after almost a decade, no longer sure whether 0x6B 0x04<br>> was Crtc enable, or Crtc scanout enable. But that only means that your<br>> previous version was not verbose enough, or was anti-verbose.<br>><br>> Luc Verhaegen<br>> _______________________________________________<br>> Openchrome-devel mailing list<br>> <a href="mailto:Openchrome-devel@lists.freedesktop.org">Openchrome-devel@lists.freedesktop.org</a><br>> <a href="https://lists.freedesktop.org/mailman/listinfo/openchrome-devel">https://lists.freedesktop.org/mailman/listinfo/openchrome-devel</a><br>>