[packagekit] [PATCH] Bug #12883, PackageKit has a hard dependency on libnm_glib
Richard Hughes
hughsient at gmail.com
Tue Oct 23 05:42:55 PDT 2007
On Tue, 2007-10-23 at 15:27 +0300, S.Çağlar Onur wrote:
> 23 Eki 2007 Sal tarihinde, Richard Hughes şunları yazmıştı:
> > > +++ b/backends/pisi/helpers/pisiBackend.py
> > ...
> > > + if self.installdb.has_package(package):
> > > + self.status(STATE_REMOVE)
> > > + try:
> > > + pisi.api.remove([package])
> > > + except pisi.Error,e:
> > > + self.error(ERROR_INTERNAL_ERROR, e)
> >
> > Can we refine this error? What could go wrong?
>
> For example PiSi won't remove any package belongs to system.base
> component for sake of system stability (this is the minimal base) and
> throws an error. There are 2-3 corner case
> exists for us.
In this case we need to throw an abstracted error, i.e. that can be
translated in the session GUI tools. What would be a good name for the
error?
ERROR_CANNOT_REMOVE_SYSTEM_BASE_PACKAGE or
ERROR_CANNOT_REMOVE_SYSTEM_PACKAGE or
ERROR_CANNOT_REMOVE_SPECIAL_PACKAGE?
and the translation:
_("Cannot remove core system package for system stability")
We can add as many error enums as we need - the more we do, the better
the translated output will be.
Richard.
More information about the PackageKit
mailing list