[packagekit] Problem running example from FAQ

Richard Hughes hughsient at gmail.com
Thu Aug 7 23:43:50 PDT 2008

On Thu, 2008-08-07 at 11:23 -0700, Dorian Perkins wrote:
> I then tried to track down which header PkPackageObj was being
> declared in. I grep'd for the string in the libpackagekit directory
> from the git main branch (0.2.3) image and noticed it was used in
> <pk-package-list.h> and <pk-package-obj.h>. Also I searched for
> "pk_package_list_get_obj" which was used in <pk-package-list.h>.
> I added those header includes to the file, tried to compile again and
> got the same errors. So I looked in /usr/include/packagekit and
> noticed that 'pk-package-obj.h' does not exist there, but
> 'pk-package-list.h' does. 

It sounds like you're using 0.2.x -- those demos were designed for 0.3.0
-- the development code. If I were you I would checkout the packagekit
git repo, and checkout the PACKAGEKIT_0_2_X branch if you're not happy
upgrading to 0.3.0 pre-release code:

git clone git://anongit.freedesktop.org/git/packagekit/PackageKit
git checkout PACKAGEKIT_0_2_X

And then look at client/pk-console.c

What distro are you using? I can send you a 0.3.0 SRPM if that's easier.

If you can jump on #PackageKit on freenode I can help you get started.


More information about the PackageKit mailing list