[packagekit] pylint madness

Anders F Björklund afb at algonet.se
Sun Sep 28 01:30:41 PDT 2008


Tim Lauridsen wrote:

> Maybe we should have an discussion about the use of pylint:
>
> - (name, idver, a, repo) = self.get_package_from_id(package_id)
> + (name, _, _, repo) = self.get_package_from_id(package_id)
>
> A change like this, to silence pylint is bad IMHO.

Another thing that I find strange is the use of abbreviations
in the formal parameters of the common methods in PackageKit.

For instance, the package methods usually take a parameter
like "pkg" and the filter methods have fields like "flt".
I understand why local variables might want shorter names
(like i,j,x,y) but why have the cryptic names in the API ?

Just an observation when looking at the:
     self.fltlist
     self.package_list
So much inconsistency in just two lines :-)

But I'll probably change the names of the variables to match
Yum's... (easier future merging, like with dispatcher/filters)

--anders




More information about the PackageKit mailing list