[Piglit] [PATCH] getactiveattrib: fix jumbled for-loop test
Ian Romanick
idr at freedesktop.org
Tue Dec 13 11:59:32 PST 2011
On 12/13/2011 05:52 AM, Brian Paul wrote:
> ---
> tests/general/getactiveattrib.c | 2 +-
> 1 files changed, 1 insertions(+), 1 deletions(-)
>
> diff --git a/tests/general/getactiveattrib.c b/tests/general/getactiveattrib.c
> index 0b11747..8fb3e26 100644
> --- a/tests/general/getactiveattrib.c
> +++ b/tests/general/getactiveattrib.c
> @@ -507,7 +507,7 @@ do_test(const struct test *tests, unsigned num_tests)
> visited_count[attr_idx]++;
> }
>
> - for (j = 0; j< tests[i].attributes[j].name != NULL; j++) {
> + for (j = 0; tests[i].attributes[j].name != NULL; j++) {
Wow. That is pretty awesome. What's even more impressive is that I
didn't notice the *3* warnings emitted by GCC for that line of code.
I'll call this reason #1 that I *hate* cmake: useful output gets lost
in all the noise it generates.
Reviewed-by: Ian Romanick <ian.d.romanick at intel.com>
> if (tests[i].attributes[j].must_be_active
> && visited_count[j] == 0) {
> DUMP_SHADER(tests[i].code);
More information about the Piglit
mailing list